Вопрос задан 05.12.2023 в 21:19. Предмет Информатика. Спрашивает Оболоник Валерия.

СРОЧНО ДАЮ 50 БАЛЛОВ! ЯЗЫК ПАСКАЛЬМаксимум и минимум из трёхЗаданы три числа.Определите какое из

них самое большее,а какое самое маленькое.Формат входных данных:Во входных данных записаны три целых числа а, b и с. Все числа не превосходят 10 000 по абсолютной величине. Формат выходных данных В первую строку выведите квадрат самого большого числа. Во вторую строку выведите квадрат самого маленького числа. ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Asanova Aisulu.

var a,b,c:integer;

begin

 writeln('введите а');

 readln(a);

   writeln('введите b');

 readln(b);

   writeln('введите c');

 readln(c);

 if (a>b) and (a>c) then writeln(a*a) else

   if (b>c) then writeln(b*b) else writeln(c*c);

 if (a<b) and (a<c) then writeln(a*a) else

   if (b<c) then writeln(b*b) else writeln(c*c)

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи мы можем использовать простой подход. Сначала мы прочитаем три числа из входных данных и присвоим их переменным a, b и c соответственно.

Затем мы сравним эти числа, чтобы определить, какое из них является самым большим и какое самым маленьким. Для этого мы можем использовать условные операторы if-else.

После определения самого большого и самого маленького чисел, мы выведем квадраты этих чисел на отдельных строках.

Вот пример кода на языке Паскаль:

``` program MaximumMinimum; var a, b, c, max, min: integer; begin readln(a, b, c); // Находим максимум max := a; if b > max then max := b; if c > max then max := c; // Находим минимум min := a; if b < min then min := b; if c < min then min := c; // Выводим квадраты максимума и минимума writeln(max * max); writeln(min * min); end. ```

Этот код считывает три числа из входных данных, находит максимум и минимум с помощью условных операторов if-else, а затем выводит квадраты этих чисел на отдельных строках.

Надеюсь, это поможет! Если у вас есть еще вопросы, пожалуйста, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос