Вопрос задан 05.12.2023 в 17:39. Предмет Информатика. Спрашивает Гредасов Егор.

10. Напишите программу, которая в последовательности натуральных чисел находит среднее

арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет на языке программирования питон
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Волк Кристина.

Ответ:

mass = [int(s) for s in input().split()]

k = 0

a = 0

for i in range(len(mass)):

   if mass[i] % 8 == 0:

       a += mass[i]

       k += 1

if k == 0:

   print('NO')

else:

   print(a / k)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на языке программирования Python можно использовать цикл, в котором будем проверять каждое число на кратность 8. Если такое число найдено, то будем суммировать его значение. После окончания цикла, если были найдены числа, кратные 8, вычислим и выведем их среднее арифметическое. Если таких чисел не было найдено, выведем "NO".

Вот пример программы, решающей данную задачу:

```python numbers = input("Введите последовательность натуральных чисел через пробел: ") numbers = numbers.split() # разделяем строку на отдельные числа count = 0 # количество чисел, кратных 8 sum_ = 0 # сумма чисел, кратных 8

for num in numbers: if int(num) % 8 == 0: # проверяем, является ли число кратным 8 count += 1 sum_ += int(num)

if count > 0: average = sum_ / count print("Среднее арифметическое чисел, кратных 8:", average) else: print("NO") ```

Программа сначала запрашивает у пользователя последовательность натуральных чисел, разделенных пробелом. Затем она разделяет введенную строку на отдельные числа и сохраняет их в переменную `numbers`. Далее, в цикле, каждое число проверяется на кратность 8 с помощью оператора `%`. Если число кратно 8, то оно увеличивает счетчик `count` и добавляется к сумме `sum_`. После окончания цикла, если были найдены числа кратные 8, вычисляется и выводится их среднее арифметическое. Если таких чисел не было найдено, выводится "NO".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос