СРОЧНО , 40 БАЛЛОВ , ПАСКАЛЬ Напишите программу, которая заполняет массив из N = 10 элементов
случайными числами в диапазоне [0,20], выводит его на экран, а затем находит индекс первого элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет. Пример: Массив: 5 16 2 13 3 14 18 13 16 9 Что ищем: 13 A[4] = 13 Напишите программу, которая заполняет массив из N =10 элементов случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет. Пример: Массив: -5 -6 2 3 -3 0 8 -3 0 9 Что ищем: 0 A[9] = 0 Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [10,50], выводит его на экран, а затем находит индексы всех элементов, равных введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет. Пример: Массив: 12 45 30 18 30 15 30 44 32 17 Что ищем: 30 A[3] = 30 A[5] = 30 A[7] = 30Ответы на вопрос
program SearchArray;
const
N = 10; // Размер массива
var
A: array[1..N] of integer; // Массив
X: integer; // Число, которое ищем
i: integer; // Итератор для циклов
found: boolean; // Флаг для проверки нахождения элемента
begin
// Заполняем массив случайными числами (допустим в диапазоне [0, 20])
randomize;
for i := 1 to N do
A[i] := random(21);
// Выводим массив на экран
writeln('Массив:');
for i := 1 to N do
write(A[i], ' ');
writeln;
// Вводим число, которое ищем
write('Что ищем: ');
readln(X);
// Ищем индекс первого элемента, равного X
found := false;
for i := 1 to N do
begin
if A[i] = X then
begin
writeln('A[', i, '] = ', X);
found := true;
break;
end;
end;
// Выводим сообщение, если элемент не найден
if not found then
writeln('Не найден');
end.
Программа на Паскале, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [0,20], выводит его на экран и находит индекс первого элемента, равного введенному числу X:
```pascal program FindIndex; var arr: array[1..10] of integer; i, X: integer; found: boolean; begin Randomize; // Инициализация генератора случайных чисел
// Заполнение массива случайными числами for i := 1 to 10 do arr[i] := Random(21);
// Вывод массива на экран for i := 1 to 10 do Write(arr[i], ' '); Writeln;
// Ввод числа X Write('Введите число X: '); Readln(X);
// Поиск индекса первого элемента, равного X found := False; for i := 1 to 10 do begin if arr[i] = X then begin found := True; Writeln('A[', i, '] = ', X); Break; end; end;
// Вывод ответа if not found then Writeln('не найден'); end. ```
Программа на Паскале, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [-10,10], выводит его на экран и находит индекс последнего элемента, равного введенному числу X:
```pascal program FindLastIndex; var arr: array[1..10] of integer; i, X, lastIndex: integer; found: boolean; begin Randomize; // Инициализация генератора случайных чисел
// Заполнение массива случайными числами for i := 1 to 10 do arr[i] := Random(21) - 10;
// Вывод массива на экран for i := 1 to 10 do Write(arr[i], ' '); Writeln;
// Ввод числа X Write('Введите число X: '); Readln(X);
// Поиск индекса последнего элемента, равного X found := False; lastIndex := 0; for i := 1 to 10 do begin if arr[i] = X then begin found := True; lastIndex := i; end; end;
// Вывод ответа if found then Writeln('A[', lastIndex, '] = ', X) else Writeln('не найден'); end. ```
Программа на Паскале, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [10,50], выводит его на экран и находит индексы всех элементов, равных введенному числу X:
```pascal program FindAllIndexes; var arr: array[1..10] of integer; i, X: integer; found: boolean; begin Randomize; // Инициализация генератора случайных чисел
// Заполнение массива случайными числами for i := 1 to 10 do arr[i] := Random(41) + 10;
// Вывод массива на экран for i := 1 to 10 do Write(arr[i], ' '); Writeln;
// Ввод числа X Write('Введите число X: '); Readln(X);
// Поиск индексов всех элементов, равных X found := False; for i := 1 to 10 do begin if arr[i] = X then begin found := True; Writeln('A[', i, '] = ', X); end; end;
// Вывод ответа if not found then Writeln('не найден'); end. ```
Надеюсь, это поможет!
Программа на Pascal для решения задачи:
``` program SearchArrayElement; var arr: array[1..10] of integer; n, x, i, index: integer; begin // Заполнение массива случайными числами Randomize; n := 10; writeln('Массив:'); for i := 1 to n do begin arr[i] := Random(21); // случайное число в диапазоне [0, 20] write(arr[i], ' '); end; writeln;
// Ввод числа, которое нужно найти write('Что ищем: '); readln(x);
// Поиск индекса первого элемента, равного введенному числу index := 0; for i := 1 to n do begin if arr[i] = x then begin index := i; break; end; end;
// Вывод результата if index > 0 then writeln('a[', index, '] = ', x) else writeln('Не найден'); end. ```
Программа заполняет массив из 10 элементов случайными числами в диапазоне [0, 20], выводит этот массив на экран, просит ввести число x, а затем находит индекс первого элемента, равного числу x, и выводит результат. Если в массиве таких элементов нет, программа выводит "Не найден".
Аналогично решаются задачи со случайными числами в других диапазонах. Необходимо только изменить значения при заполнении массива (arr[i] := Random(21); для первой задачи, arr[i] := Random(21) - 10; для второй задачи, arr[i] := Random(41) + 10; для третьей задачи) и изменить подходящий текст сообщения о результатах в выводе.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
