Напишите программу, которая вычисляет периметр прямоугольника по двум его сторонам. Заготовка var
?:integer; begin read(?); s:=???; write(???): ?Ответы на вопрос
program perimetr;
var
p, a, b: integer;
begin
write ('Введите сторону a: '); readln(a);
write ('Введите сторону b: '); readln(b);
p := 2*(a+b);
write ('Периметр прямоугольника со стороной a=', a ,' и b=', b ,' равен: ', p);
end.
Для вычисления периметра прямоугольника по двум его сторонам можно использовать следующую программу:
var a, b, p: integer; begin write('Введите длину первой стороны прямоугольника: '); readln(a); write('Введите длину второй стороны прямоугольника: '); readln(b); p := 2 * (a + b); // формула для вычисления периметра прямоугольника writeln('Периметр прямоугольника равен: ', p); end.
В данной программе мы объявляем переменные a, b и p типа integer, которые будут хранить значения длин сторон прямоугольника и его периметр соответственно.
Затем с помощью функции readln считываем значения первой и второй сторон прямоугольника и сохраняем их в переменные a и b.
Далее, используя формулу для вычисления периметра прямоугольника (p = 2 * (a + b)), вычисляем периметр и сохраняем его в переменную p.
И наконец, с помощью функции writeln выводим результат на экран.
Таким образом, после ввода значений сторон прямоугольника, программа выведет его периметр.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
