Вопрос задан 20.11.2023 в 22:17. Предмет Информатика. Спрашивает Иванов Никита.

Напишите программу, которая будет суммировать вводимые с клавиатуры числа до тех пор, пока с

клавиатуры не вводиться число 111. Напишите на языке питон. Прикрепить скрин кода и результата.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Михайлов Андрей.

Ответ:

total = 0

while True:

   number = int(input("Введіть число: "))

   if number == 111:

       break

   total += number

print("Сума чисел:", total)


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Приведенный ниже код на языке Python реализует программу, которая будет суммировать числа, вводимые с клавиатуры, до тех пор, пока не будет введено число 111:

```python sum = 0

while True: num = int(input("Введите число: ")) if num == 111: break sum += num

print("Сумма введенных чисел:", sum) ```

Пояснения к коду:

- Создаем переменную `sum` и инициализируем ее нулем. - Запускаем бесконечный цикл с помощью конструкции `while True`. - Внутри цикла запрашиваем у пользователя ввод числа с помощью функции `input()`, преобразуем его в целое число с помощью `int()` и сохраняем в переменную `num`. - Проверяем, равно ли введенное число 111. Если да, то прерываем цикл с помощью ключевого слова `break`. - Иначе, прибавляем введенное число к переменной `sum`. - После выхода из цикла выводим на экран сумму введенных чисел.

Пример работы программы:

``` Введите число: 5 Введите число: 10 Введите число: 15 Введите число: 111 Сумма введенных чисел: 30 ```

Скриншот кода и результата работы программы можно прикрепить в виде отдельного изображения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос