
Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне
от -100 до 100, и выводит сумму четных чисел (в Visual Studio)

Ответы на вопрос




Для решения данной задачи в Visual Studio можно написать программу на языке C++, которая будет генерировать и выводить на экран массив с 10 случайных чисел в диапазоне от -100 до 100, а затем выводить сумму четных чисел.
Вот пример программы:
```cpp
#include
int main() { // Инициализация генератора случайных чисел srand(time(0));
const int size = 10; int numbers[size]; int sum = 0;
// Заполнение массива случайными числами и вывод на экран std::cout << "Массив случайных чисел: "; for (int i = 0; i < size; i++) { numbers[i] = rand() % 201 - 100; // Генерация числа от -100 до 100 std::cout << numbers[i] << " "; } std::cout << std::endl;
// Вычисление суммы четных чисел for (int i = 0; i < size; i++) { if (numbers[i] % 2 == 0) { sum += numbers[i]; } }
// Вывод суммы четных чисел std::cout << "Сумма четных чисел: " << sum << std::endl;
return 0; } ```
В этой программе мы используем функцию `srand(time(0))` для инициализации генератора случайных чисел. Затем мы создаем массив `numbers` размером 10 и заполняем его случайными числами в диапазоне от -100 до 100 с помощью `rand() % 201 - 100`. Затем мы выводим массив на экран.
Далее мы вычисляем сумму четных чисел, перебирая элементы массива и проверяя их на четность с помощью оператора `%`. Если число четное, мы добавляем его к переменной `sum`.
Наконец, мы выводим сумму четных чисел на экран.
Вы можете скопировать этот код в Visual Studio и запустить программу, чтобы увидеть результат.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili