Вопрос задан 16.11.2023 в 18:02. Предмет Информатика. Спрашивает Войцехович Андрій.

ДАЮ 60 БАЛЛОВ Задача по программированию. Дать код только на питоне, паскали и другой дичи не

надо. Условие: В каждой строке сначала записан номер класса (число, равное 9, 10 или 11), затем (через пробел) — фамилия ученика. Необходимо вывести список школьников по классам: сначала всех учеников 9 класса, затем — 10, затем — 11. Внутри одного класса порядок вывода фамилий должен быть таким же, как на входе. Формат входных данных: В первой строке записано число n (3 ⩽ n ⩽ 1000) — количество записей. В каждой из следующих n строк сначала записан номер класса (число, равное 9, 10 или 11), затем (через пробел) — фамилия ученика. Формат выходных данных: Необходимо вывести список школьников по классам: сначала всех учеников 9 класса, затем — 10, затем — 11. Внутри одного класса порядок вывода фамилий должен быть таким же, как на входе. Пример: ввод: 6 9 Ivanov 10 Petrov 11 Sidorov 9 Grigoryev 9 Sergeev 10 Yakovlev вывод: 9 Ivanov 9 Grigoryev 9 Sergeev 10 Petrov 10 Yakovlev 11 Sidorov
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шматкова Саша.

Ответ:

n = int(input())

pupilsNine = []

pupilsTen = []

pupilsEleven = []

for i in range(0, n):

   arr = input().split(' ')

   if arr[0] == '9':

       pupilsNine.append(arr[1])

   elif arr[0] == '10':

       pupilsTen.append(arr[1])

   elif arr[0] == '11':

       pupilsEleven.append(arr[1])

for i in pupilsNine:

   print(f"9 {i}")

for i in pupilsTen:

   print(f"10 {i}")

for i in pupilsEleven:

   print(f"11 {i}")

0 0
Отвечает Котик Настя.

print(*[f"{data[0]} {data[1]}" for data in sorted([(input().split( )) for _ in range(int(*[n for n in [int(input())] if 3 <= n <= 1000 ]))], key=lambda x: int(x[0]))], sep='\n')

ето одна строчка ^_^

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на языке Python, можно воспользоваться следующим кодом:

```python n = int(input()) # количество записей students = {} # создаем пустой словарь для хранения учеников по классам

# заполняем словарь учениками for _ in range(n): class_num, surname = input().split() class_num = int(class_num) if class_num not in students: students[class_num] = [] students[class_num].append(surname)

# выводим список учеников по классам for class_num in sorted(students.keys()): for surname in students[class_num]: print(class_num, surname) ```

Пояснение: 1. Сначала мы получаем количество записей в переменную `n`. 2. Затем создаем пустой словарь `students`, где ключами будут номера классов, а значениями – списки фамилий учеников. 3. Далее, в цикле заполняем словарь, считывая номер класса и фамилию ученика, и добавляя фамилию в соответствующий список для данного класса. 4. В конце, выводим список учеников по классам, сортируя ключи словаря в порядке возрастания, а затем для каждого класса выводим фамилии учеников в том порядке, в котором они были получены на входе.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос