Составить программу в Паскале Вводиться вещественное число.Если оно не отрицательное ,то найти и
вывести его корень квадратный ,в противном случае-вывести текст «нельзя извлечь корень» Например :введите число 16 Корень квадратный из 16=4Ответы на вопрос
Ответ:
var a, b, i:Integer;
begin
write('Введите число: ');
readln(i);
if (i >= 0) then
writeln('Корень квадратный из ', i, ' = ', sqrt(i))
else
writeln('Нельзя извлечь квадратный корень!');
end.
Программа на Паскале, которая выполняет указанные условия:
```pascal program SquareRoot; var number, squareRoot: real; begin write('Введите число: '); readln(number); if number >= 0 then begin squareRoot := sqrt(number); writeln('Корень квадратный из ', number, ' = ', squareRoot:0:2); end else writeln('Нельзя извлечь корень'); end. ```
Описание программы: 1. Объявляем две переменные типа real: `number` для хранения введенного числа и `squareRoot` для хранения корня квадратного числа. 2. Выводим сообщение с просьбой ввести число. 3. Считываем число с клавиатуры и сохраняем его в переменную `number`. 4. Проверяем условие: если число `number` больше или равно нулю, то выполняется блок кода внутри `begin...end`. 5. Внутри блока кода вычисляем корень квадратный числа `number` с помощью функции `sqrt()` и сохраняем результат в переменную `squareRoot`. 6. Выводим сообщение, которое содержит введенное число и его корень квадратный, с округлением до двух знаков после запятой. 7. Если число `number` меньше нуля, то выполняется блок кода после ключевого слова `else`. 8. Внутри блока кода после `else` выводим сообщение, что нельзя извлечь корень из отрицательного числа. 9. Конец программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
