Написать программу, которая вычисляет возраст пользователя, который вводит свой год рождения и
выдает рекомендацию по времени занятий спортом: если возраст меньше 40, пробегать 6 км в день, если больше 40 и меньше 55, то пробегать 4 км в день, в остальных случаях – не более 2 км в день. только на С++Ответы на вопрос
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL, "Rus");
int year,yeart = 2022,output;
cout << "Сейчас " << yeart << " год" << endl;
cout << "Введите свой год рождения: ";
cin >> year;
if(year > 2022){
cout << "Ваш год рождения не может быть больше чем " << yeart << endl;
return 1;
}
else{
output = yeart - year;
cout << "Вам примерно: " << output << endl;
switch(output){
case 0 ... 39:{
cout << "6 км в день" << endl;
break;
}
case 40 ... 54:{
cout << "4 км в день" << endl;
break;
}
default:{
cout << "Не более 2 км " << endl;
break;
}
}
}
return 0;
}
Конечно, вот пример программы на языке программирования C, которая выполняет указанные вами задачи:
```c
#include
int main() { // Объявление переменных int birthYear, age; // Ввод года рождения printf("Введите год рождения: "); scanf("%d", &birthYear); // Вычисление возраста age = 2023 - birthYear;
// Вывод возраста printf("Ваш возраст: %d лет\n", age);
// Рекомендации по занятиям спортом if (age < 40) { printf("Рекомендуется пробегать 6 км в день.\n"); } else if (age >= 40 && age < 55) { printf("Рекомендуется пробегать 4 км в день.\n"); } else { printf("Рекомендуется не более 2 км в день.\n"); }
return 0; } ```
Эта программа запрашивает у пользователя год рождения, вычисляет возраст и в зависимости от возраста выводит рекомендации по занятиям спортом. Пожалуйста, учтите, что в реальных условиях лучше было бы обеспечить дополнительную проверку ввода пользователя и обработку возможных ошибок.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
