Вопрос задан 13.11.2023 в 14:30. Предмет Информатика. Спрашивает Ибрагимов Даниил.

Написать программу, которая: создает два массива (массив A и массив B) из 10 случайных элементов

(от -10 до 10), проверяет на знак элементы массива А и в случае, если они отрицательны, заменяет их значениями массива В с тем же номером. Пример: А 9 8 -4 5 3 -2 Б 1 2 3 4 2 9 Результат: А 9 8 3 5 3 9
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лотайчук Алина.

Ответ:

import random

a = []

b = []

for i in range(10):

   a.append(random.randint(-10, 10))

for i in range(10):

   b.append(random.randint(-10, 10))

print(f'A = {a}')

print(f'B = {b}')

for i in range(len(a)):

   if a[i] < 0:

       a[i] = b[i]

print(f'New A = {a}')

Объяснение:

P.S прогнав программу увидел что она работает правильно, но бывают такие случае что в а число отрицательное, оно заменяет на б с таким же индексом , но это тоже отрецательное число))


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам написать программу, которая делает то, что вы просили. Вот один из возможных вариантов решения на языке Python:

```python # Импортируем модуль random для генерации случайных чисел import random

# Создаем два массива A и B из 10 случайных элементов от -10 до 10 A = [random.randint(-10, 10) for _ in range(10)] B = [random.randint(-10, 10) for _ in range(10)]

# Выводим исходные массивы на экран print("A =", A) print("B =", B)

# Проверяем на знак элементы массива A и в случае, если они отрицательны, заменяем их значениями массива B с тем же номером for i in range(len(A)): if A[i] < 0: A[i] = B[i]

# Выводим результат на экран print("Результат:") print("A =", A) ```

Надеюсь, это было полезно. Если у вас есть еще вопросы, я буду рад ответить.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос