
СДЕЛАТЬ В PascalABC.net. ДАЮ 100 БАЛЛОВ!!! Задано время отправления поезда и время в пути до
конечной станции. Требуется написать программу, которая найдет время прибытия этого поезда (возможно, в другие сутки). Входные данные Входной файл INPUT.TXT содержит две строки. В первой строке задано время отправления, а во второй строке – время в пути. Время отправления задается в формате «HH:MM», где HH время в часах, которое принимает значение от 00 до 23, ММ – время в минутах, которое принимает значение от 00 до 59. Время в пути задается двумя неотрицательными целыми числами – количество часов и количество минут. Числа разделяются одним пробелом. Количество часов не превышает 120, минут – 59. Выходные данные Выходной файл OUTPUT.TXT должен содержать одну строку – время прибытия поезда на конечную станцию. Формат вывода этого времени совпадает с форматом ввода времени отправления.

Ответы на вопрос

Программа находит время прибытия поезда на конечную станцию. Для этого нужно сначала считать данные из входного файла INPUT.TXT, затем вычислить время прибытия и записать его в выходной файл OUTPUT.TXT.
Пример решения данной задачи на PascalABC.net:
```pascal program TrainArrivalTime;
var departureTime, travelTime, arrivalTime: string; hours, minutes, totalHours, totalMinutes: integer;
begin assign(input, 'INPUT.TXT'); reset(input); readln(departureTime); readln(hours, minutes); close(input);
totalHours := StrToInt(Copy(departureTime, 1, 2)) + hours; totalMinutes := StrToInt(Copy(departureTime, 4, 2)) + minutes;
if totalMinutes >= 60 then begin totalHours := totalHours + 1; totalMinutes := totalMinutes - 60; end;
if totalHours >= 24 then begin totalHours := totalHours - 24; end;
if totalHours < 10 then begin arrivalTime := '0' + IntToStr(totalHours) + ':'; end else begin arrivalTime := IntToStr(totalHours) + ':'; end;
if totalMinutes < 10 then begin arrivalTime := arrivalTime + '0' + IntToStr(totalMinutes); end else begin arrivalTime := arrivalTime + IntToStr(totalMinutes); end;
assign(output, 'OUTPUT.TXT'); rewrite(output); writeln(arrivalTime); close(output); end. ```
Данная программа считывает время отправления и время в пути из входного файла, вычисляет время прибытия и записывает его в выходной файл.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili