Вопрос задан 13.11.2023 в 08:35. Предмет Информатика. Спрашивает Шишкина Катя.

Помогите скласть программу в Paskal Составить программу для вычисления суммы чисел от 1 до 20

включительно, результат вывести На экране 1)с оператором while 2)с оператором for
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Малина Алина.

var

i, _sum : integer;

begin

i := 1;

while i <= 20 do

   begin

   _sum := _sum + i;

   i := i + 1;

   end;

writeln(_sum);

end.

var

i, _sum : integer;

begin

for i := 1 to 20 do

   _sum := _sum + i;

writeln(_sum);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для вычисления суммы чисел от 1 до 20 включительно и вывода результата на экран может быть написана на языке Паскаль.

1) С использованием оператора while:

``` program SummationWhile;

var sum, num: integer; begin sum := 0; num := 1;

while num <= 20 do begin sum := sum + num; num := num + 1; end;

writeln('Сумма чисел от 1 до 20: ', sum); end. ``` В данной программе переменная `sum` инициализируется нулем, а переменная `num` устанавливается равной 1. Затем в цикле while проверяется условие `num <= 20`, и пока оно истинно, выполняется блок кода внутри цикла. Внутри цикла переменная `sum` увеличивается на значение `num`, затем значение `num` увеличивается на 1. После выполнения цикла значение `sum` содержит сумму чисел от 1 до 20, которое выводится на экран с помощью процедуры `writeln`.

2) С использованием оператора for:

``` program SummationFor;

var sum, num: integer; begin sum := 0;

for num := 1 to 20 do begin sum := sum + num; end;

writeln('Сумма чисел от 1 до 20: ', sum); end. ``` В данной программе переменная `sum` инициализируется нулем. Затем в цикле for переменная `num` принимает значения от 1 до 20 включительно. В каждой итерации цикла значение `sum` увеличивается на значение `num`. После выполнения цикла значение `sum` содержит сумму чисел от 1 до 20, которое выводится на экран с помощью процедуры `writeln`.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос