Вопрос задан 29.07.2018 в 13:32. Предмет Информатика. Спрашивает Решанов Даниил.

Составьте программу вычисления значения функции в visual basicХ^3-2, Х<0y=X+3, X>=0это

системаОчень срочно!!! пожалуйста помогите!!!!))))
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Позывной Данил.

Program Funkiya;

Var X , Y: integer;

begin

Write ('введите число Х');

Read (X);

Write ('введите число Y');

Read (Y);

If X < 0 then Y:= X*X*X - 2

else Y: = X + 3;

Write ('Y =', Y);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Visual Basic, которая вычисляет значение функции в зависимости от введенного значения X:

```vb Sub Main() Dim X As Double Dim Y As Double

Console.Write("Введите значение X: ") X = Double.Parse(Console.ReadLine())

If X < 0 Then Y = Math.Pow(X, 3) - 2 Else Y = X + 3 End If

Console.WriteLine("Значение функции Y = " & Y)

Console.ReadLine() End Sub ```

В этой программе мы сначала запрашиваем у пользователя значение X. Затем мы используем условный оператор `If` для проверки значения X. Если X меньше нуля, то мы вычисляем значение функции Y = X^3 - 2. Если X больше или равно нулю, то мы вычисляем значение функции Y = X + 3. Наконец, мы выводим значение функции на экран.

Примечание: В этом примере предполагается, что вы используете консольное приложение Visual Basic. Если вы используете другой тип приложения, например, Windows Forms или WPF, код может отличаться.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос