Вопрос задан 06.11.2023 в 03:42. Предмет Информатика. Спрашивает Дашко Даниил.

Двумерные массивы, Python Найдите наибольший элемент в массивах a, b, c и его номер. Можно без

объяснений, просто код который набрать, ещё лучше файлом) (даю 100 баллов)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чистова Юлия.

Ответ:

from random import random

N = 10

arr = [0] * N

mx = 0

for i in range(N):

   arr[i] = random() * 100

   print("%.2f" % arr[i], end='; ')

   if arr[i] > arr[mx]:

       mx = i

print("\narr[%d] = %.2f" % (mx, arr[mx]))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам нужно пройти по каждому из трех двумерных массивов, найти наибольший элемент в каждом из них и сохранить его вместе с его индексами. Давайте предположим, что у вас есть три двумерных массива `a`, `b` и `c`.

В Python вы можете использовать функцию `max()` для нахождения наибольшего элемента в списке. Однако, чтобы получить индексы этого элемента, вам нужно использовать аргумент `key` функции `max()`, который позволяет задать функцию, определяющую, по какому критерию следует сравнивать элементы. В данном случае, критерием будет значение элемента, а функцией - просто функция идентичности `lambda x: x`.

Вот как это может выглядеть на Python:

```python # Предположим, что a, b, c - это ваши двумерные массивы a = [[1, 2, 3], [4, 5, 6], [7, 8, 9]] b = [[10, 11, 12], [13, 14, 15], [16, 17, 18]] c = [[19, 20, 21], [22, 23, 24], [25, 26, 27]]

# Функция для нахождения наибольшего элемента и его индексов def max_element_and_index(matrix): max_value = max(matrix, key=lambda x: max(x)) max_index = matrix.index(max_value) max_subindex = max_value.index(max(max_value)) return max_value, max_index, max_subindex

# Нахождение наибольшего элемента и его индексов в каждом из массивов max_a, index_a, subindex_a = max_element_and_index(a) max_b, index_b, subindex_b = max_element_and_index(b) max_c, index_c, subindex_c = max_element_and_index(c)

# Вывод результатов print(f"Максимальный элемент в a: {max_a}, его индексы: ({index_a}, {subindex_a})") print(f"Максимальный элемент в b: {max_b}, его индексы: ({index_b}, {subindex_b})") print(f"Максимальный элемент в c: {max_c}, его индексы: ({index_c}, {subindex_c})") ```

Этот код сначала определяет функцию `max_element_and_index()`, которая принимает двумерный массив, находит в нем наибольший элемент и возвращает его значение, а также индексы его строки и столбца. Затем этот код применяет эту функцию к каждому из трех двумерных массивов и выводит результаты.

Обратите внимание, что индексация в Python начинается с 0, поэтому индексы строк и столбцов будут на единицу меньше, чем вы ожидаете, если считать с 1 , , , .

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос