Составить программу для перевода суммы из долларов в рубли. Вводиться текущий курс доллара и сумма
в долларах. Результат должен выводиться в денежном формате 345 РУБ 40 КОП ПАСКАЛЬОтветы на вопрос
Ответ:
var
kurs, summa, rub: double;
begin
readln(kurs, summa);
rub := kurs * summa;
writeln(trunc(rub), ' РУБ ', (frac(rub) * 100):2:0, ' КОП');
end.
Объяснение:
Получаем два числа, затем перемножаем курс на сумму в долларах, чтобы получить рубли и затем выводим в нужном формате.
trunc(a) получает целую часть от числа
frac(a) получает дробную часть от числа, затем умножаем на 100 для преобразования дробной части в целую(для вывода на экран) (например число 0.22 преобразуется в 22.0) и с помощью :2:0 выводим в формате 2 цифры до запятой и 0 после.
Программа для перевода суммы из долларов в рубли на языке Pascal может выглядеть следующим образом:
```pascal program ConvertCurrency;
var exchangeRate, amountInDollars: real; amountInRubles, rubles, kopeks: integer;
begin // Ввод текущего курса доллара writeln('Введите текущий курс доллара:'); readln(exchangeRate);
// Ввод суммы в долларах writeln('Введите сумму в долларах:'); readln(amountInDollars);
// Перевод суммы из долларов в рубли amountInRubles := round(amountInDollars * exchangeRate * 100);
// Разделение рублей и копеек rubles := amountInRubles div 100; kopeks := amountInRubles mod 100;
// Вывод результата в денежном формате writeln('Результат: ', rubles, ' РУБ ', kopeks, ' КОП'); end. ```
Программа сначала запрашивает текущий курс доллара, затем сумму в долларах. Затем она производит перевод суммы из долларов в рубли, умножая сумму в долларах на текущий курс и умножая результат на 100 для сохранения копеек. Затем программа разделяет рубли и копейки, используя операции деления и остатка от деления. Наконец, программа выводит результат в денежном формате, где рубли и копейки разделены пробелом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
