Даны два одномерных массива А и В состоящие из N целых чисел каждый. Массив А заполнен числами в
интервале от -43 до +47, амассив В от -36 до +51. Написать программу, которая формирует новыймассив С, элементами которого является среднее арифметическоеСоответствующих элементов массива А и В.Помогите пожалуйста!!!Задача на PascalОтветы на вопрос
Ответ:
program z1;
var i,N:integer;
A:array [1..315] of integer;
B:array [1..315] of integer;
C:array [1..315] of real;
begin
randomize;
write('Введите количество элементов массивов (N <= 315) N = ');
readln(N);
write('Массив А: ');
for i:=1 to N do
begin
A[i]:=random(91)-43;
write(A[i]:7)
end;
writeln;
write('Массив В: ');
for i:=1 to N do
begin
B[i]:=random(88)-36;
write(B[i]:7)
end;
writeln;
write('Массив С: ');
for i:=1 to N do
begin
C[i]:=(A[i] + B[i]) / 2;
write(C[i]:7:1)
end
end.
Объяснение:
Вводим количество элементов в массивах (N <= 315)
Заполняем первый массив и выводим на экран
Заполняем второй массив и выводим на экран
Формируем третий массив и выводим на экран
Вот пример программы на языке Pascal, которая решает данную задачу:
```pascal program AverageArrayElements;
const N = 10; // количество элементов в массивах
var A, B, C: array[1..N] of Integer; // объявление массивов i: Integer; // переменная для цикла
begin // заполнение массивов A и B случайными числами Randomize; for i := 1 to N do begin A[i] := Random(91) - 43; // случайное число от -43 до 47 B[i] := Random(88) - 36; // случайное число от -36 до 51 end;
// формирование массива C средними арифметическими элементов массивов A и B for i := 1 to N do begin C[i] := (A[i] + B[i]) div 2; // среднее арифметическое end;
// вывод массива C writeln('Массив C:'); for i := 1 to N do begin write(C[i], ' '); end; writeln; end. ```
В этой программе мы объявляем три одномерных массива: A, B и C, каждый из которых содержит N элементов типа Integer. Затем мы заполняем массивы A и B случайными числами в заданных интервалах. Для этого мы используем функцию Random, которая генерирует случайное число в заданном диапазоне.
Затем мы формируем массив C, элементами которого являются средние арифметические соответствующих элементов массивов A и B. Для этого мы используем цикл, который проходит по всем элементам массивов A и B и вычисляет среднее арифметическое.
Наконец, мы выводим массив C на экран.
Примечание: В этом примере мы предполагаем, что вы уже знакомы с основами программирования на языке Pascal. Если у вас возникнут вопросы по коду или его работе, не стесняйтесь задавать их.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
