
Напишите программу, которая переводит цифровую систему отметок в словесную. Например если
пользователь ввел оценку "5", на экран выводится словесная отметка "Пятерка"

Ответы на вопрос

Ответ:
var i:integer;
begin
writeln('Введите оценку'); readln(i);
case i of
1: writeln('Единица');
2: writeln('Двойка');
3: writeln('Тройка');
4: writeln('Четверка');
5: writeln('Пятерка');
else writeln('Нет такой оценки');
end;
readln;
end.
Объяснение:



Для создания программы, которая будет переводить цифровую систему отметок в словесную, нам необходимо определить список возможных отметок и их соответствующие словесные значения. В случае с оценками, мы можем использовать следующий список:
отметки = { '2': 'Двойка', '3': 'Тройка', '4': 'Четверка', '5': 'Пятерка' }
Затем, мы можем написать следующую программу на языке Python, чтобы пользователь мог вводить оценки и получать соответствующую им словесную отметку:
# Определение списка отметок отметки = { '2': 'Двойка', '3': 'Тройка', '4': 'Четверка', '5': 'Пятерка' }
# Получение оценки от пользователя оценка = input('Введите оценку: ')
# Проверка, есть ли оценка в списке if оценка in отметки: # Вывод словесной отметки print(отметки[оценка]) else: # Вывод сообщения об ошибке print('Такой оценки не существует')
Программа сначала определяет список отметок, затем запрашивает оценку пользователя с помощью функции input(). Затем она проверяет, есть ли оценка в списке отметок с помощью условного оператора if. Если оценка есть в списке, программа выводит соответствующую соответствующую отметку, в противном случае выводит сообщение об ошибке.


Похожие вопросы







Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili