Вопрос задан 04.11.2023 в 21:14. Предмет Информатика. Спрашивает Горин Полина.

Pascal ABC. Составьте программу, выводящую на экран фрагмент таблицы умножения: 1 x 1 = 12 х 2 =

43 x 3 = 9... 9 х 9 = 81​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Климушин Саша.

Ответ:

Program tablitsa;

Begin;

WriteLn ('Таблица умножения');

WriteLn ('1*1=1');

WriteLn ('2*2=4');

WriteLn ('3*3=9');

WriteLn ('4*4=16');

WriteLn ('5*5=25');

WriteLn ('6*6=36');

WriteLn ('7*7=49');

WriteLn ('8*8=64');

WriteLn ('9*9=81');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для создания программы на Pascal ABC, которая будет выводить на экран фрагмент таблицы умножения, вы можете использовать следующий код:

```pascal program MultiplicationTableFragment; var x, y, result: integer; begin for x := 1 to 9 do begin for y := 1 to 9 do begin result := x * y; writeln(x, ' x ', y, ' = ', result); end; end; end. ```

Этот код создает два вложенных цикла, один для переменной `x` и один для переменной `y`. Затем внутри циклов происходит умножение `x` на `y`, и результат сохраняется в переменной `result`. Затем результат выводится на экран с помощью процедуры `writeln`. Программа будет выполняться для значений `x` от 1 до 9 и `y` от 1 до 9, что создаст фрагмент таблицы умножения от 1x1 до 9x9.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос