Вопрос задан 30.10.2023 в 03:05. Предмет Информатика. Спрашивает Шабаева Диана.

Срочно!!!!!! Pascal ABC a) составьте программу выводящую на экран фрагмент таблицы умножения

:1*2=22*2=43*2=69*2=18б) Составьте программу выводящую на экран фрагмент таблицы умножения:1*1=12*2=43*3=99*9=81​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Колотилов Роман.

Ответ:

1)

begin

 for var i := 1 to 10 do begin

   var ch := i*2;

   Writeln(i,'*2=',ch);

   end;

end.

2)

begin

 for var i := 1 to 9 do begin

   var ch := i*i;

   Writeln(i,'*',i,'=',ch);

   end;

end

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal ABC, которая выводит на экран фрагмент таблицы умножения: a) ```pascal program multiplicationTableA; var i: integer; begin for i := 1 to 9 do writeln(i, '* 2 = ', i*2); end. ``` b) ```pascal program multiplicationTableB; var i, j: integer; begin for i := 1 to 3 do begin for j := 1 to 3 do writeln(j, '* ', i, ' = ', i*j); writeln; end; end. ``` Программа a) выводит на экран умножение чисел от 1 до 9 на 2. Результат выглядит следующим образом: 1 * 2 = 2 2 * 2 = 4 3 * 2 = 6 4 * 2 = 8 5 * 2 = 10 6 * 2 = 12 7 * 2 = 14 8 * 2 = 16 9 * 2 = 18 Программа b) выводит на экран умножение чисел от 1 до 3 на числа от 1 до 3. Результат выглядит следующим образом: 1 * 1 = 1 2 * 1 = 2 3 * 1 = 3 1 * 2 = 2 2 * 2 = 4 3 * 2 = 6 1 * 3 = 3 2 * 3 = 6 3 * 3 = 9
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с программированием на языке PascalABC.NET. Это современный язык программирования, основанный на языке Паскаль, но с множеством расширений и возможностей платформы .NET. Вы можете скачать бесплатную среду разработки PascalABC.NET с встроенным конструктором форм для создания приложений для Windows .

Вы задали мне две задачи по составлению программ, выводящих на экран фрагменты таблицы умножения. Я попробую решить их для вас.

a) Составьте программу, выводящую на экран фрагмент таблицы умножения:

1*2=2

2*2=4

3*2=6

9*2=18

Для этой задачи можно использовать цикл for, который повторяет действия для каждого значения переменной от 1 до 9. В теле цикла нужно вывести на экран произведение переменной и числа 2, используя оператор writeln. Программа может выглядеть так:

```pascal program Table; begin for var i := 1 to 9 do writeln(i, '*2=', i*2); end. ```

б) Составьте программу, выводящую на экран фрагмент таблицы умножения:

1*1=1

2*2=4

3*3=9

9*9=81

Для этой задачи можно также использовать цикл for, но в этом случае нужно вывести на экран квадрат переменной, используя оператор writeln и функцию sqr. Программа может выглядеть так:

```pascal program Square; begin for var i := 1 to 9 do writeln(i, '*', i, '=', sqr(i)); end. ```

Надеюсь, что эти примеры помогут вам понять, как работать с языком PascalABC.NET. Если у вас есть еще вопросы, я буду рад ответить на них.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос