Написать программу, составить блок-схему к задачам 1. Найти корни квадратного уравнения и вывести
их на экран, если они есть. Если корней нет, то вывести сообщение об этом. Конкретное квадратное уравнение определяется коэффициентами a, b, c, которые вводит пользователь. 2. По длинам трех отрезков, введенных пользователем, определить возможность существования треугольника, составленного из этих отрезков. Если такой треугольник существует, то определить, является ли он разносторонним, равнобедренным или равносторонним.Ответы на вопрос
Ответ:
Первое кому-то уже решал вчера на с++. Скрин прикрепляю.
Объяснение:

Задача 1: Найти корни квадратного уравнения
Для решения задачи по нахождению корней квадратного уравнения и их вывода на экран, можно написать программу на языке программирования C++. Вот пример такой программы:
```cpp
#include
int main() { double a, b, c; double discriminant, root1, root2;
// Ввод коэффициентов a, b и c std::cout << "Введите коэффициент a: "; std::cin >> a; std::cout << "Введите коэффициент b: "; std::cin >> b; std::cout << "Введите коэффициент c: "; std::cin >> c;
// Вычисление дискриминанта discriminant = b * b - 4 * a * c;
// Проверка наличия корней if (discriminant > 0) { // Вычисление корней root1 = (-b + std::sqrt(discriminant)) / (2 * a); root2 = (-b - std::sqrt(discriminant)) / (2 * a);
// Вывод корней на экран std::cout << "Корень 1: " << root1 << std::endl; std::cout << "Корень 2: " << root2 << std::endl; } else if (discriminant == 0) { // Вычисление и вывод одного корня на экран root1 = -b / (2 * a); std::cout << "Единственный корень: " << root1 << std::endl; } else { // Вывод сообщения о отсутствии корней std::cout << "Корней нет" << std::endl; }
return 0; } ```
Эта программа позволяет пользователю ввести коэффициенты квадратного уравнения и выводит на экран его корни, если они существуют. Если корней нет, программа выведет сообщение об этом.
Задача 2: Определение треугольника по длинам отрезков
Для определения возможности существования треугольника и его типа (разносторонний, равнобедренный или равносторонний) на основе длин трех отрезков, можно написать программу на языке программирования C++. Вот пример такой программы:
```cpp
#include
int main() { double a, b, c;
// Ввод длин отрезков std::cout << "Введите длину первого отрезка: "; std::cin >> a; std::cout << "Введите длину второго отрезка: "; std::cin >> b; std::cout << "Введите длину третьего отрезка: "; std::cin >> c;
// Проверка условия существования треугольника if (a + b > c && a + c > b && b + c > a) { // Проверка типа треугольника if (a == b && b == c) { std::cout << "Треугольник равносторонний" << std::endl; } else if (a == b || b == c || a == c) { std::cout << "Треугольник равнобедренный" << std::endl; } else { std::cout << "Треугольник разносторонний" << std::endl; } } else { std::cout << "Треугольник с такими сторонами не существует" << std::endl; }
return 0; } ```
Эта программа позволяет пользователю ввести длины трех отрезков и определяет возможность существования треугольника, а также его тип (разносторонний, равнобедренный или равносторонний). Если треугольник с заданными сторонами не существует, программа выведет соответствующее сообщение.
Примечание: В обоих примерах программы предполагается, что пользователь вводит корректные значения коэффициентов и длин отрезков. Если пользователь вводит некорректные значения, программа может дать непредсказуемый результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
