
100 БАЛЛОВ Написать программу на языке Паскаль для решения следующей задачи:Дано четырехзначное
число, которое вводится с клавиатуры пользователем. Посчитать количество четных и нечетных цифр во введенном числе.На проверку нужно прислать СКРИНШОТЫ окна программы с кодом и результатами работы. Входные данные задать самостоятельно.

Ответы на вопрос

##
uses School;
var n := ReadInteger;
var ko := n.Digits.Where(t-> t.IsOdd).Count;
Print('Нечетных', ko, 'четных', 4 - ko)




Программа на языке Паскаль для решения данной задачи может выглядеть следующим образом:
```pascal program CountEvenOddDigits; var number, digit, evenCount, oddCount: integer; begin evenCount := 0; oddCount := 0;
writeln('Введите четырехзначное число:'); readln(number);
// Проверяем каждую цифру числа while number > 0 do begin digit := number mod 10; // Получаем последнюю цифру числа number := number div 10; // Убираем последнюю цифру числа
if digit mod 2 = 0 then evenCount := evenCount + 1 // Увеличиваем счетчик четных цифр else oddCount := oddCount + 1; // Увеличиваем счетчик нечетных цифр end;
writeln('Количество четных цифр:', evenCount); writeln('Количество нечетных цифр:', oddCount); end. ```
При запуске программы пользователь должен ввести четырехзначное число. Например, можно ввести число 1234.
После выполнения программы на экране появятся следующие результаты:
``` Количество четных цифр: 2 Количество нечетных цифр: 2 ```
На скриншоте будет видно окно программы с кодом и результатами работы программы.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili