Глава 3. Программирование § 18. Линейные программы 1. Требуется написать программу, которая
складывает два числа и выводит на экран их сумму. Определите входные данные и результат этого алгоритма. К какому типу относятся входные данные: Сколько входных значений у алгоритма? К какому типу относятся результаты: Сколько результатов у алгоритма? Обозначьте именами входные данные и результаты и напишите их на стрелках: Запишите формулу, которая связывает исходные данные и результат: Место для ввода текста. 2. Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма. К какому типу относятся входные данные: Сколько входных значений у алгоритма? К какому типу относятся результаты: Сколько результатов у алгоритма? Обозначьте именами входные данные и результаты и напишите их на стрелках: Запишите формулу, которая связывает исходные данные и результат: Место для ввода текста. 3. В языке C++ целые переменные относятся к типу int. Выясните, откуда произошло сокращение int в языках программирования: int – это сокращение от английского слова , которое переводится как . 4. Выделите красным цветом (или зачеркните) недопустимые имена переменных: 1 Vasya СУ-27 @mail_ru m11 Петя СУ_27 lenta.ru 1m Митин брат _27 "Pes barbos" m 1 Quo vadis СУ(27) 5. Что появится на экране после выполнения программы: int c = 5; cout ' " << "b!"; Ответ: в) int a = 5, b = 3; cout << "(" << a << ")<(" << a+b << ")"; Ответ: 25. Запишите оператор для вывода значений целых переменных a = 5 и b = 3 в формате: а) 3+5=? б) (5)(3) в) a=5; b=3; г) Ответ: (5;3) 26. Вычислите значение вещественной переменной c при a = 2 и b = 3: а) с = a + 1. / 3; б) с = a + 4. / 2 * 3 + 6; в) с = (a + 4) / 2. * 3; г) с = (a + 4.) /(b + 3) * a; 27. Вычислите значение целочисленной переменной c при a = 26 и b = 6: а) c = a % b + b; б) c = a / b + a; в) b = a / b; c = a / b; г) b = a / b + b; c = a % b + a; д) b = a % b + 4; c = a % b + 1; е) b = a / b; c = a % (b+1); ж) b = a % b; c = a / (b+1); 28. Выполните предыдущее задание при a = –22 и b = 4. а) c = a % b + b; б) c = a / b + a; в) b = a / b; c = a / b; г) b = a / b + b; c = a % b + a; д) b = a % b + 4; c = a % b + 1; е) b = a / b; c = a % (b+1); ж) b = a % b; c = a / (b+1); 29. *Используя дополнительные источники, выясните, правильно ли (с точки зрения математики) в языке C++ вычисляется остаток от деления, если одно из чисел отрицательное. Место для ввода текста. 30. Требовалось написать программу, которая меняет местами значения двух переменных в памяти. Программист торопился и написал программу так: a = b; b = a; Выполните ручную прокрутку программы при a = 1, b = 2: a b 1 2 a = b; b = a; Исправьте программу и выполните её ручную прокрутку: a b 1 2 31. *Попробуйте найти решение предыдущей задачи, которое не использует дополнительные переменные. a b 1 2Ответы на вопрос
Ответ:
Объяснение:
1) #include <iostream>
using namespace std;
int main()
{
int a, b;
cout<<"Enter number 1";
cin >> a;
cout<<"Enter number 2";
cin >> b;
int res = a + b;
cout << "Result - " << res << endl;
return 0;
}
1.1) К целочисленному типу
1.2)2 входных значения
1.3)1 результат
1.4)(я не понимаю какие стрелки)
1.5)A + B = RES
2) #include <iostream>
using namespace std;
int main()
{
float speed, time;
cout<<"Enter speed";
cin >> speed;
cout<<"Enter time";
cin >> time;
int length = speed * time;
cout << "Length- " << length << endl;
return 0;
}
2.1) К дробному типу
2.2)2 входных значения
2.3)1 результат
2.4)(я не понимаю какие стрелки)
2.5)S = V * t
3. Слово Integer
4. можно: Vasya СУ-27 @mail_ru
m11 Петя СУ_27 lenta.ru
m 1 Quo vadis СУ(27)
нельзя: 1m Митин брат _27 "Pes barbos"
5. b!
6. в)
1. Программа, которая складывает два числа и выводит их сумму: Входные данные: Два целых числа. - Входные значения: 2 - Тип входных данных: int - Количество входных значений: 2
Результаты: Сумма двух чисел. - Результат: 4 - Тип результата: int - Количество результатов: 1
Имена входных данных и результатов: - Входные данные: a, b - Результат: sum
Формула: sum = a + b
2. Программа, которая выводит скорость и время движения автомобиля и выводит расстояние, которое он проехал:
Входные данные: Скорость (вещественное число) и время (вещественное число) движения. - Входные значения: Скорость = 60 км/ч, Время = 2 часа - Тип входных данных: float - Количество входных значений: 2
Результаты: Расстояние (вещественное число), которое автомобиль проехал. - Результат: 120 км - Тип результата: float - Количество результатов: 1
Имена входных данных и результатов: - Входные данные: speed, time - Результат: distance
Формула: distance = speed * time
3. Сокращение "int" в языках программирования произошло от английского слова "integer," которое переводится как "целое число."
4. Недопустимые имена переменных: Vasya, СУ-27, @mail_ru, m11, Петя, СУ_27, lenta.ru, 1m, Митин, брат, _27, "Pes barbos", m, 1, Quo vadis, СУ(27).
5. После выполнения программы `int c = 5; cout << "b!";` на экране будет выведено: `b!`
6. Операторы для вывода значений целых переменных `a` и `b` в формате `(5)(3)` можно записать как: `(a)(b)`.
7. Вычисление значения вещественной переменной `c` при `a = 2` и `b = 3`:
а) `c = a + 1 / 3` => `c = 2 + 1 / 3` => `c = 2.3333...`
б) `c = a + 4 / (2 * 3) + 6` => `c = 2 + 4 / 6 + 6` => `c = 2 + 2/3 + 6` => `c = 2.6666...`
в) `c = (a + 4) / (2 * 3)` => `c = (2 + 4) / (2 * 3)` => `c = 6 / 6` => `c = 1`
г) `c = (a + 4.) / (b + 3) * a` => `c = (2 + 4.) / (3 + 3) * 2` => `c = 6. / 6 * 2` => `c = 2`
8. Вычисление значения целочисленной переменной `c` при `a = 26` и `b = 6`:
а) `c = a % b + b` => `c = 26 % 6 + 6` => `c = 2 + 6` => `c = 8`
б) `c = a / b + a` => `c = 26 / 6 + 26` => `c = 4 + 26` => `c = 30`
в) `b = a / b; c = a / b` => `b = 26 / 6` => `b = 4` => `c = 26 / 4` => `c = 6`
г) `b = a / b + b; c = a % b + a` => `b = 26 / 6 + 6` => `b = 4 + 6` => `b = 10`, `c = 26 % 10 + 26` => `c = 6 + 26` => `c = 32`
д) `b = a % b + 4; c = a % b + 1` => `b = 26 % 6 + 4` => `b = 2 + 4` => `b = 6`, `c = 26 % 6 + 1` => `c = 2 + 1` => `c = 3`
е) `b = a / b; c = a % (b + 1)` => `b = 26 / 6` => `b = 4`, `c = 26 % (4 + 1)` => `c = 26 % 5` => `c = 1`
ж) `b = a % b; c = a / (b + 1)` => `b = 26 % 6` => `b = 2`, `c = 26 / (2 + 1)` => `c = 26 / 3` => `c = 8`
9. Остаток от деления в языке C вычисляется так: если оба числа положительные, то остаток от деления положительный, если одно из чисел отрицательное, то остаток от деления будет таким же знаком, как у делимого.
10. Программа `a += b; b += a;` некорректно меняет местами значения переменных `a` и `b`. После выполнения этой программы, оба `a` и `b` будут содержать сумму исходных значений. Ручная прокрутка программы:
- Исходные значения: a = 1, b = 2 - a += b; // a = 3, b = 2 - b += a; // a = 3, b = 5
Исправленная программа для обмена значениями переменных
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
