Дан массив из 100 целых чисел. Написать программу нахождения суммы нечетных элементов массива. C++
Ответы на вопрос
Ответ:
#include <iostream>
#include <time.h>
using namespace std;
int main()
{
srand(time(NULL));
int N[100];
int sum = 0;
for(int i=0;i<100;i++){
N[i] =rand();
}
cout << "vse elementu" << endl;
for(int i=0;i<100;i++)
cout << N[i] << " ";
cout << endl;
cout << "nechetnue elementu" << endl;
for(int i=0;i<100;i++){
if(N[i]%2!=0)
sum = sum + N[i];
cout << N[i] << " ";
}
cout << endl;
cout<< "suma nechetnuh = " << sum << endl;
system("pause");
return 0;
}
Объяснение:
Написал программу так, что-бы сначала выводило 100 элементов(рандом чисел), потом выводило нечетные элементы, потом выведет уже суму нечетных
Конечно, вот пример программы на C++ для нахождения суммы нечетных элементов в массиве из 100 целых чисел:
```cpp
#include
int main() { int array[100]; // Объявляем массив из 100 целых чисел int sum = 0; // Переменная для хранения суммы нечетных элементов
// Заполняем массив случайными числами (ваш код может отличаться) for (int i = 0; i < 100; i++) { array[i] = rand() % 100; // Генерируем случайное число от 0 до 99 }
// Находим сумму нечетных элементов for (int i = 0; i < 100; i++) { if (array[i] % 2 != 0) { // Проверяем, является ли элемент нечетным sum += array[i]; // Если да, добавляем его к сумме } }
// Выводим сумму нечетных элементов std::cout << "Сумма нечетных элементов массива: " << sum << std::endl;
return 0; } ```
В этой программе:
1. Мы объявляем массив `array` из 100 целых чисел для хранения данных. 2. Заполняем массив случайными целыми числами (в диапазоне от 0 до 99), но вы можете заполнить его данными, какими вам нужно. 3. Затем мы используем цикл `for`, чтобы пройти по массиву и проверить каждый элемент. Если элемент нечетный (проверка с помощью оператора `%`), мы добавляем его к переменной `sum`. 4. Наконец, выводим сумму нечетных элементов на экран.
После выполнения программы, вы увидите сумму всех нечетных элементов в массиве.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
