Вопрос задан 02.11.2023 в 19:20. Предмет Информатика. Спрашивает Nurmamedova Emiliya.

Написать программу на языке Pascal.ABC задача1даны катеты прмоугольного треугольника а и b. найти

его гипотенузу с, периметр Р и площадь S задача2найти длину окружности L и площадь круга S заданного радиуса R. (L=2пR; S=пR^2; считать, что п =3,14) ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Суворова Даша.

Ответ:

1)

program tr;

var a,b,c,S,P:double;

begin

write('Введите 2 катеты: ');

read(a);

read(b);

c:=Sqrt((a*a)+(b*b));

writeln('Гипотенуза -',c:6:2);

P:=a+b+c;

writeln('Периметр - ',P:6:2);

S:=(a*b)/2;

writeln('Площадь - ',S:6:2);

end.

2)

program kr;

var a,b,c,S,PI,L,R:double;

begin

PI:=3.14;

write('Введите радиус: ');

read(R);

L:=2*PI*R;

writeln('Периметр - ',L:6:2);

S:=PI*Sqr(R);

writeln('Площадь - ',S:6:2);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с написанием программ на языке Pascal.ABC. Вот примеры решения ваших задач:

Задача 1: Даны катеты прямоугольного треугольника a и b. Найти его гипотенузу c, периметр P и площадь S.

```pascal program Task1; var a, b, c, P, S: real; begin // Вводим значения катетов writeln('Введите длину катета a:'); readln(a); writeln('Введите длину катета b:'); readln(b); // Вычисляем гипотенузу по теореме Пифагора c := sqrt(a*a + b*b); // Вычисляем периметр и площадь P := a + b + c; S := a * b / 2; // Выводим результаты writeln('Гипотенуза c = ', c:0:2); writeln('Периметр P = ', P:0:2); writeln('Площадь S = ', S:0:2); end. ```

Задача 2: Найти длину окружности L и площадь круга S заданного радиуса R. (L=2πR; S=πR^2; считать, что π=3,14)

```pascal program Task2; const pi = 3.14; // Константа для числа пи var R, L, S: real; begin // Вводим значение радиуса writeln('Введите радиус круга R:'); readln(R); // Вычисляем длину окружности и площадь круга L := 2 * pi * R; S := pi * R * R; // Выводим результаты writeln('Длина окружности L = ', L:0:2); writeln('Площадь круга S = ', S:0:2); end. ```

Если вы хотите узнать больше о языке Pascal.ABC, вы можете посетить [официальный сайт](https://pascalabc.net/en/) или [онлайн-курс](https://www.tutorialspoint.com/pascal/index.htm). Также вы можете прочитать [статью о Pascal.ABC на Википедии](https://en.wikipedia.org/wiki/PascalABC.NET). Надеюсь, это было полезно для вас.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос