Дан двумерный массив целых чисел. а) Составить программу, определяющую, верно ли, что сумма
элементовстроки массива с известным номером оканчивается цифрой 0.ПОЖАЛУЙСТА СРОЧНО! МОЖНО ЧЕРЕЗ С++ И ПОЛНОСТЬЮ КОД, ДАМ 20 БАЛЛОВОтветы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main()
{
int line, column;
cout << "Введите количество строк и столбцов через пробел: ";
cin >> line >> column;
int array[50][50] = {};
cout << "Введите элементы двумерного массива: \n";
for (int i = 0; i < line; i++ )
{
for (int j = 0; j < column; j++)
{
cin >> array[i][j];
}
cout << endl;
}
int amount = 0;
int line_index;
cout << "Введите индекс строки массива: ";
cin >> line_index;
for (int j = 0; j < column; j++)
{
int i = line_index;
amount += array[i][j];
}
if (amount % 10 == 0)
{
cout << "YES";
}
else
{
cout << "NO";
}
}
Объяснение:
#include <iostream> // Библиотека ввода - вывода
using namespace std; // Пространство имен
int main()
{
int line, column; // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве
cout << "Введите количество строк и столбцов через пробел: "; // Вывод сообщения в консоль
cin >> line >> column; // Ввод количества строк и столбцов с клавиатуры
int array[50][50] = {}; // Создание целочисленного массива размером 50х50
cout << "Введите элементы двумерного массива: \n"; // Вывод сообщения в консоль
for (int i = 0; i < line; i++ ) // Ввод элементов массива
{ // Ввод элементов массива
for (int j = 0; j < column; j++) // Ввод элементов массива
{ // Ввод элементов массива
cin >> array[i][j]; // Ввод элементов массива
} // Ввод элементов массива
cout << endl; // Ввод элементов массива
} // Ввод элементов массива
int amount = 0; // Создание целочисленной переменной, хранящей сумму нужной строки
int line_index; // Переменная, хранящая индекс нужной строки
cout << "Введите индекс строки массива: "; // Вывод сообщения в консоль
cin >> line_index; // Ввод индекса нужной строки с клавиатуры
for (int j = 0; j < column; j++) // Находим все элементы нужной строки
{
int i = line_index; // Нужна сумма определенной строки ⇒ значение переменной i будет постоянным
amount += array[i][j]; // Переменная, хранящая сумму элементов нужной строки, суммируется с элементами строки
}
if (amount % 10 == 0) // Если последняя цифра суммы = 0
{
cout << "YES"; // Выводим "YES"
}
else // Иначе
{
cout << "NO"; // Выводим "NO"
}
}
Для решения этой задачи вам нужно написать программу на C++, которая будет принимать двумерный массив целых чисел и номер строки. Затем программа должна суммировать элементы этой строки и проверять, оканчивается ли полученная сумма на цифру 0.
Вот шаги, которые вам нужно выполнить:
1. Создайте двумерный массив целых чисел. 2. Запросите у пользователя номер строки, которую нужно проверить. 3. Используйте цикл `for` или `while` для суммирования элементов выбранной строки. 4. Проверьте, оканчивается ли полученная сумма на цифру 0. 5. Если сумма оканчивается на 0, выведите сообщение, что условие выполнено. В противном случае выведите сообщение, что условие не выполнено.
Вот пример кода на C++:
```cpp
#include
int main() { int arr[5][5] = { /* ваш двумерный массив */ }; int row;
cout << "Введите номер строки: "; cin >> row;
int sum = 0; for(int i = 0; i < 5; i++) { sum += arr[row][i]; }
if(sum % 10 == 0) { cout << "Сумма элементов строки оканчивается на 0." << endl; } else { cout << "Сумма элементов строки не оканчивается на 0." << endl; }
return 0; } ```
Этот код сначала запрашивает у пользователя номер строки для проверки. Затем он проходит по всем элементам этой строки и суммирует их. Наконец, он проверяет, оканчивается ли полученная сумма на 0, и выводит соответствующее сообщение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
