Вопрос задан 02.11.2023 в 10:04. Предмет Информатика. Спрашивает Горохова Ольга.

Помогите пожалуйста,я написал программу,она неправильно работает,напишите пожалуйста

правильно,PYTHON. Напишите программу, которая запрашивает у пользователя его возраст (целое число лет) и в зависимости от значения введённого числа выводит: • от 0 до 7 — «Вам в детский сад»; • от 7 до 18 — «Вам в школу»; • от 18 до 25 — «Вам в профессиональное учебное заведение»; • от 25 до 60 — «Вам на работу»; • от 60 до 120 — «Вам предоставляется выбор»; • меньше 0 и больше 120 — пять раз подряд: «Ошибка! Это программа для людей!».
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Черкасов Дима.

age = int(input("Сколько Вам лет? "))

if 0 <= age <7:

   print("Вам в детский сад")

elif 7 <= age <18:

   print("Вам в школу")

elif 18 <= age <25:

   print("Вам профессиональное учебное заведение")

elif 25 <= age <60:

   print("Вам на работу")

elif 60 <= age <120:

   print("Вам предоставляется выбор")

elif age < 0 or age > 120:

   for i in range(5):

       print("Ошибка! Это программа для людей!")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для написания программы на Python, которая выполняет указанные действия, вам нужно использовать условные операторы. Вот пример программы, которая делает то, что вы описали:

```python # Запрос возраста у пользователя age = int(input("Введите ваш возраст (целое число лет): "))

# Проверка возраста и вывод соответствующего сообщения if 0 <= age <= 7: print("Вам в детский сад") elif 7 < age <= 18: print("Вам в школу") elif 18 < age <= 25: print("Вам в профессиональное учебное заведение") elif 25 < age <= 60: print("Вам на работу") elif 60 < age <= 120: print("Вам предоставляется выбор") else: print("Ошибка! Это программа для людей!") ```

Эта программа сначала запрашивает у пользователя его возраст, затем сравнивает введенное значение с заданными интервалами и выводит соответствующее сообщение в зависимости от значения возраста.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос