Напишите программу в Паскаль . Где нужно ввести стоимость за 1 кг крупы .Вывести стоимость за
100.200.300 и так до 1000гр Заранее спасибо .решите подробно .Ответы на вопрос
Ответ:
program Ves;
var v,s: real;
begin
write ('Введите стоимость 1 кг крупы: ');
readln (s);
v := 100;
while v <= 1000 do
begin
writeln(v:4,' г крупы стоит ', v*s/1000:5,' y.e.');
v := v + 100
end
end.
Объяснение:
write ('Введите стоимость 1 кг крупы: '); - выводим на экран надпись
readln (s); - вводим значение стоимости за 1 кг крупы
v := 100; - задаём начальный вес
while v <= 1000 do - используем цикл с предусловием
begin - используем составной оператор
writeln(v:4,' г крупы стоит ', v*s/1000:5,' y.e.'); - выводим на экран надпись, используем форматированный вывод, формулу берем из пропорции
1000 г - s (стоимость 1 кг крупы)
v (вес) - ?
? = v * s / 1000
v := v + 100 - увеличиваем вес на 100
end - используем составной оператор
Ответ:
Потому что идёт раздражение клеток и не будет меня любить и
Конечно, вот пример программы на языке Паскаль, которая выполняет расчет стоимости крупы за различное количество грамм:
```pascal program Расчет_стоимости_крупы;
var Цена_за_кг, Стоимость: real; Вес_грамм: integer;
begin writeln('Введите стоимость за 1 кг крупы: '); readln(Цена_за_кг);
writeln('---------------------------'); writeln('Вес | Стоимость'); writeln('---------------------------');
for Вес_грамм := 100 to 1000 step 100 do begin Стоимость := (Цена_за_кг / 1000) * Вес_грамм; writeln(Вес_грамм, ' г | ', Стоимость:0:2); end;
writeln('---------------------------'); end. ```
Объяснение программы:
1. `Цена_за_кг` - переменная для хранения стоимости за 1 кг крупы. 2. `Стоимость` - переменная для вычисления стоимости для определенного веса крупы. 3. `Вес_грамм` - переменная, используемая в цикле для изменения веса от 100 до 1000 грамм с шагом 100. 4. Пользователю предлагается ввести стоимость за 1 кг крупы. 5. Затем цикл `for` перебирает вес от 100 до 1000 грамм с шагом 100. 6. В каждой итерации цикла программа вычисляет стоимость для заданного веса, используя формулу `(Цена_за_кг / 1000) * Вес_грамм`. 7. Результат выводится на экран, отображая вес и соответствующую стоимость. 8. Программа завершает работу.
Пример работы программы:
``` Введите стоимость за 1 кг крупы: 5.25 --------------------------- Вес | Стоимость --------------------------- 100 г | 0.53 200 г | 1.05 300 г | 1.58 400 г | 2.10 500 г | 2.63 600 г | 3.15 700 г | 3.68 800 г | 4.20 900 г | 4.73 1000 г | 5.25 --------------------------- ```
Вы можете ввести свою собственную цену за килограмм крупы и программа автоматически выведет стоимость для 100, 200, 300 и так далее до 1000 грамм.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
