Вопрос задан 08.07.2023 в 19:01. Предмет Информатика. Спрашивает Максимов Максим.

1. Написать программу на языке Паскаль (линейный алгоритм) Найти произведение значений двух

переменных и вывести результат на экран. 2. Написать программу на языке Паскаль (разветвляющийся алгоритм) Ввести два числа. Вычесть из большего меньшее. 3. Написать программу на языке Паскаль (алгоритмы с циклом) 3.1. Вывести на экран 3 раза свое ФИО. Особенность: одинаковые действия выполняются 3 раза. 3.2. Вычислить сумму ряда S = 1+1.5+2+2.5+3+3.5+…+ 20. 3.3. Написать программу ввода неопределённого ряда целых чисел до тех пор, пока не будет введён 9. После ввода 9 программа должна вывести сообщение «Программа заверщена».
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Биличенко Виктория.

1

var

ch1, ch2: Integer;

begin

readln(ch1, ch2);

WriteLn(ch1*ch2);

end.

2

var

ch1, ch2: Integer;

begin

readln(ch1, ch2);

WriteLn(abs(ch1-ch2));

end.

3.1

var

i:Integer;

begin

for i:=1 to 3 do

WriteLn('ФИО')

end.

3.2

var

ch, sum: real;

begin

sum:=0;

ch :=1;

while ch <= 20 do

begin

sum:= sum +ch;

ch:=ch+0.5;

end;

WriteLn(sum);

end .

3.3

var

ch:LongInt;

begin

ReadLn(ch);

while (ch>9) or (ch<9) do

begin

ReadLn(ch);

end ;

WriteLn('Программа завершена');

end .

как лучший

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль (линейный алгоритм) для нахождения произведения двух переменных и вывода результата на экран:

pascal
program LinearAlgorithm; var var1, var2, result: integer; begin writeln('Введите первую переменную: '); readln(var1); writeln('Введите вторую переменную: '); readln(var2); result := var1 * var2; writeln('Произведение равно: ', result); end.

Программа на языке Паскаль (разветвляющийся алгоритм) для вычитания меньшего числа из большего:

pascal
program BranchingAlgorithm; var num1, num2, difference: integer; begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); if num1 > num2 then difference := num1 - num2 else difference := num2 - num1; writeln('Разность равна: ', difference); end.

Программа на языке Паскаль (алгоритмы с циклом) для выполнения различных задач:

3.1. Вывести на экран 3 раза свое ФИО:

pascal
program LoopAlgorithm; var i: integer; name: string; begin name := 'Ваше ФИО'; for i := 1 to 3 do writeln(name); end.

3.2. Вычислить сумму ряда S = 1+1.5+2+2.5+3+3.5+...+20:

pascal
program LoopAlgorithm; var i: integer; sum: real; begin sum := 0; for i := 1 to 20 do begin if i mod 2 = 0 then sum := sum + i / 2 else sum := sum + i; end; writeln('Сумма ряда равна: ', sum); end.

3.3. Написать программу ввода неопределённого ряда целых чисел до тех пор, пока не будет введён 9. После ввода 9 программа должна вывести сообщение «Программа завершена»:

pascal
program LoopAlgorithm; var num: integer; begin repeat writeln('Введите число: '); readln(num); until num = 9; writeln('Программа завершена'); end.

Обратите внимание, что ввод и вывод данных в консоли может отличаться в различных средах разработки или интерпретаторах, поэтому вы можете адаптировать код в соответствии с вашей средой выполнения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос