Вопрос задан 01.11.2023 в 20:24. Предмет Информатика. Спрашивает Фомин Егор.

Задача 1. Составить программу, которая запрашивает у пользователя два числа (m, n), находит их

сумму (S) и произведение (P). Сравнивает значения суммы и произведения и выводит сообщение какое больше (сумма или произведение) и на сколько. Иногда в задачах требуется выполнение не одного, а нескольких условий или одного из нескольких. Тогда простые условия образуют составные при помощи логических операций and или or.Формат записи составного условия:(условие 1) and (условие 2) and…and (условие N)(условие 1) or (условие 2) or…or (условие N)Задача 2. В школу танцев принимаются учащиеся не выше 178 см и не ниже 168 см. Написать программу, которая определяет, будете ли Вы приняты в школу танцев.Условие:if (rost<178) and (rost>168) then write (‘Приняты!‘) else write (‘ Не приняты!‘);Задача 3. Составить программу, которая определяет, является ли данное число трехзначным и выводит сообщение об этом (двузначным является число от 10 до 99).Задача 4. На работу в компанию принимаются люди не старше 42 лет и имеющие стаж работы не менее 5 лет. Написать программу, которая определяет, будет кандидат принят на работу или нет.Задача 5. Дано некоторое число b. Составить программу, которая удваивает данное число если оно, принадлежит интервалу [m;n], ыв противном случае заменяет его на противоположное.PS: pascal(не турбо),всем буду благодарен!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Цуба Ваня.
Задание 2
Program ada4a2;
Var rost:Integer;
Begin
  WriteLn('Введите ваш возраст: ');
  Read(rost);
  If (rost<178) and (rost>168) Then Write('Приняты')
                               Else Write('Не приняты');
ReadLn;
End.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задача 1: Составить программу, которая запрашивает у пользователя два числа (m, n), находит их сумму (S) и произведение (P). Сравнивает значения суммы и произведения и выводит сообщение, какое больше (сумма или произведение) и на сколько.

Вот пример программы на языке Pascal, которая решает данную задачу:

```pascal program CompareNumbers; var m, n, S, P: integer; begin // Ввод чисел m и n write('Введите число m: '); readln(m); write('Введите число n: '); readln(n); // Вычисление суммы и произведения S := m + n; P := m * n; // Сравнение суммы и произведения if S > P then writeln('Сумма больше произведения на ', S - P) else if P > S then writeln('Произведение больше суммы на ', P - S) else writeln('Сумма и произведение равны'); end. ```

Программа запрашивает у пользователя два числа `m` и `n`, вычисляет их сумму `S` и произведение `P`, а затем сравнивает значения суммы и произведения. В зависимости от результата сравнения, программа выводит соответствующее сообщение.

Задача 2: В школу танцев принимаются учащиеся не выше 178 см и не ниже 168 см. Написать программу, которая определяет, будете ли Вы приняты в школу танцев.

Вот пример программы на языке Pascal, которая решает данную задачу:

```pascal program DanceSchool; var height: integer; begin // Ввод роста write('Введите Ваш рост (в см): '); readln(height); // Проверка условия принятия в школу танцев if (height <= 178) and (height >= 168) then writeln('Вы приняты в школу танцев') else writeln('Вы не приняты в школу танцев'); end. ```

Программа запрашивает у пользователя его рост в сантиметрах и проверяет, соответствует ли он условиям принятия в школу танцев. Если рост находится в диапазоне от 168 до 178 см включительно, программа выводит сообщение "Вы приняты в школу танцев". В противном случае, программа выводит сообщение "Вы не приняты в школу танцев".

Задача 3: Составить программу, которая определяет, является ли данное число трехзначным и выводит сообщение об этом (двузначным является число от 10 до 99).

Вот пример программы на языке Pascal, которая решает данную задачу:

```pascal program CheckNumber; var number: integer; begin // Ввод числа write('Введите число: '); readln(number); // Проверка условия трехзначности числа if (number >= 100) and (number <= 999) then writeln('Данное число является трехзначным') else if (number >= 10) and (number <= 99) then writeln('Данное число является двузначным') else writeln('Данное число не является трехзначным или двузначным'); end. ```

Программа запрашивает у пользователя число и проверяет, является ли оно трехзначным или двузначным. Если число находится в диапазоне от 100 до 999 включительно, программа выводит сообщение "Данное число является трехзначным". Если число находится в диапазоне от 10 до 99 включительно, программа выводит сообщение "Данное число является двузначным". В противном случае, программа выводит сообщение "Данное число не является трехзначным или двузначным".

Задача 4: На работу в компанию принимаются люди не старше 42 лет и имеющие стаж работы не менее 5 лет. Написать программу, которая определяет, будет кандидат принят на работу или нет.

Вот пример программы на языке Pascal, которая решает данную задачу:

```pascal program JobApplication; var age, experience: integer; begin // Ввод возраста и стажа работы write('Введите Ваш возраст: '); readln(age); write('Введите Ваш стаж работы (в годах): '); readln(experience); // Проверка условия принятия на работу if (age <= 42) and (experience >= 5) then writeln('Вы приняты на работу') else writeln('Вы не приняты на работу'); end. ```

Программа запрашивает у пользователя его возраст и стаж работы в годах, а затем проверяет, соответствует ли он условиям принятия на работу в компанию. Если возраст не превышает 42 года и стаж работы составляет не менее 5 лет, программа выводит сообщение "Вы приняты на работу". В противном случае, программа выводит сообщение "Вы не приняты на работу".

Задача 5: Дано некоторое число b. Составить программу, которая удваивает данное число, если оно принадлежит интервалу [m;n], в противном случае заменяет его на противоположное.

Вот пример программы на языке Pascal, которая решает данную задачу:

```pascal program DoubleOrNegate; var b, m, n: integer; begin // Ввод числа b и интервала [m;n] write('Введите число b: '); readln(b); write('Введите нижнюю границу интервала m: '); readln(m); write('Введите верхнюю границу интервала n: '); readln(n); // Проверка условий и преобразование числа b if (b >= m) and (b <= n) then b := 2 * b else b := -b; // Вывод результата writeln('Результат: ', b); end. ```

Программа запрашивает у пользователя число `b` и интервал `[m;n]`. Затем она проверяет, принадлежит ли число `b` интервалу `[m;n]`. Если да, то число `b` удваивается. В противном случае, число `b` заменяется на противоположное. Результат выводится на экран.

Надеюсь, эти примеры программ помогут вам решить поставленные задачи! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос