Вопрос задан 01.11.2023 в 10:35. Предмет Информатика. Спрашивает Тасуев Анзор.

Задача №1: Напишите программу, которая в последовательности натуральных чисел определяет количество

двузначных четных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Задача №2: Напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое чисел, кратных 7, или сообщает что таких чисел нет (выводит "NO"). Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. PASCAL , задания написать отдельно
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Попов Ваня.

===== PascalABC.NET =====

=1=

begin

 var n := ReadInteger;

 ReadSeqInteger(n).Count(p -> p.IsEven and p.InRange(10, 99)).Print

end.

=2=

begin

 var n := ReadInteger;

 var m := ReadSeqInteger(n)

       .Where(p -> p mod 7 = 0)

       .DefaultIfEmpty

       .Average;

 if m = 0 then

   Print('NO')

 else

   Print(m)

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, давайте начнем с написания программы на языке Pascal для решения задачи №1: определения количества двузначных четных чисел в последовательности.

```pascal program CountEvenTwoDigitNumbers; var n, num, count: integer; begin count := 0;

writeln('Введите количество чисел в последовательности:'); readln(n);

writeln('Введите числа:'); for var i := 1 to n do begin readln(num); if (num >= 10) and (num <= 99) and (num mod 2 = 0) then count := count + 1; end;

writeln('Количество двузначных четных чисел в последовательности: ', count); end. ```

Теперь перейдем ко второй задаче: определению среднего арифметического чисел, кратных 7, или выводу "NO", если таких чисел нет.

```pascal program AverageOfMultiplesOfSeven; var n, num, sum, count: integer; average: real; begin sum := 0; count := 0;

writeln('Введите количество чисел в последовательности:'); readln(n);

writeln('Введите числа:'); for var i := 1 to n do begin readln(num); if num mod 7 = 0 then begin sum := sum + num; count := count + 1; end; end;

if count > 0 then begin average := sum / count; writeln('Среднее арифметическое чисел, кратных 7: ', average:0:2); end else begin writeln('NO'); end; end. ```

Оба этих примера программ работают с последовательностью натуральных чисел и выполняют заданные операции. Первая программа находит количество двузначных четных чисел, а вторая программа определяет среднее арифметическое чисел, кратных 7, или выводит "NO", если таких чисел нет.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос