Помогите пожалуйста. Дан массив из 10 целых чисел. Написать программу нахождения суммы
положительных элементов массива ПаскальОтветы на вопрос
var
mas: array[1..10] of integer;
i, sum: integer;
begin
sum:=0;
for i:=1 to 10 do
begin
write(i, ' элемент массива: ');
readln(mas[i]);
if mas[i] > 0 then
sum:=sum+mas[i];
end;
writeln('Сумма положительных элементов массива: ', sum);
end.
Вот пример программы на языке Паскаль, которая находит сумму положительных элементов массива из 10 целых чисел:
```pascal program SumOfPositiveElements;
var arr: array[1..10] of integer; i, sum: integer;
begin sum := 0;
writeln('Введите 10 целых чисел:'); for i := 1 to 10 do begin readln(arr[i]);
if arr[i] > 0 then sum := sum + arr[i]; end;
writeln('Сумма положительных элементов массива: ', sum);
readln; end. ```
Программа начинается с объявления переменных `arr` - массива из 10 целых чисел, `i` - переменной для цикла, и `sum` - переменной, в которой будет храниться сумма положительных элементов массива.
Затем программа запрашивает у пользователя ввод 10 целых чисел и сохраняет их в массив `arr`. После каждого ввода числа, программа проверяет, является ли оно положительным (больше нуля) и, если да, то добавляет его к сумме `sum`.
После завершения цикла, программа выводит на экран сумму положительных элементов массива.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
