Вопрос задан 30.10.2023 в 01:44. Предмет Информатика. Спрашивает Долгов Андрей.

Напишите программу на С++ Известна зарплата каждого из 12 работников фирмы за каждый месяц

первого квартала (3 месяца) определите А. Общую сумму выплаченую Всем работникам Б. Зарплату полученую каждым работником за квартал В. Общую зарплату всех работников за каждый месяц
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Маковеев Ваня.

===== C++ 17 =====

#include <iostream>

using namespace std;

int main()

{

   srand(time(NULL));

   int n = 12, k = 3;

   int a[k][n];

   for(int i = 0; i < k; i++)

   {

       for(int j = 0; j < n; j++)

       {

           a[i][j] = (rand() % 35 + 25) * 1000;

           cout << a[i][j] << " ";

       }

       cout << endl;

   }

   cout << "\nОбщая сумма, выплаченная всем работникам: ";

   int s = 0;

   for(int i = 0; i < k; i++)

       for(int j = 0; j < n; j++)

           s += a[i][j];

   cout << s << "\nЗарплаты каждого работника за квартал:\n";

   s = 0;

   for(int j = 0; j < n; j++)

   {

       s = 0;

       for(int i = 0; i < k; i++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << "\nОбщие зарплаты всех работников по месяцам: ";

   for(int i = 0; i < k; i++)

   {

       s = 0;

       for(int j = 0; j < n; j++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << endl;

   return 0;

}


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на С++ для расчета общей суммы, зарплаты каждого работника за квартал и общей зарплаты всех работников за каждый месяц, известная зарплата каждого из 12 работников фирмы за каждый месяц первого квартала (3 месяца): ```cpp #include using namespace std; int main() { const int numOfWorkers = 12; // Количество работников const int numOfMonth = 3; // Количество месяцев в квартале double salary[numOfWorkers][numOfMonth]; // Массив зарплат работников // Ввод зарплаты каждого работника за каждый месяц cout << "Введите зарплаты работников за каждый месяц первого квартала:\n"; for (int i = 0; i < numOfWorkers; i++) { for (int j = 0; j < numOfMonth; j++) { cout << "Работник " << i + 1 << ", Месяц " << j + 1 << ": "; cin >> salary[i][j]; } } double totalSum = 0; // Общая сумма выплаченная всем работникам double totalSumPerMonth[numOfMonth] = {0}; // Общая зарплата всех работников за каждый месяц // Расчет общей суммы и зарплаты каждого работника за квартал for (int i = 0; i < numOfWorkers; i++) { double sumPerWorker = 0; // Зарплата работника за квартал for (int j = 0; j < numOfMonth; j++) { sumPerWorker += salary[i][j]; totalSum += salary[i][j]; totalSumPerMonth[j] += salary[i][j]; } cout << "Зарплата работника " << i + 1 << " за квартал: " << sumPerWorker << endl; } cout << "Общая сумма выплаченная всем работникам: " << totalSum << endl; // Вывод общей зарплаты всех работников за каждый месяц for (int i = 0; i < numOfMonth; i++) { cout << "Общая зарплата всех работников за Месяц " << i + 1 << ": " << totalSumPerMonth[i] << endl; } return 0; } ``` Программа позволяет пользователю ввести зарплату каждого работника за каждый месяц первого квартала (3 месяца). Затем она выполняет следующие расчеты: - Суммирует зарплату каждого работника за весь квартал и выводит ее на экран. - Суммирует зарплаты всех работников за каждый месяц и выводит эту информацию на экран. - Суммирует зарплаты всех работников за весь квартал и выводит эту информацию на экран.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос