50 баллов. PascalABC Дан текст, состоящий из слов: между словами произвольное число пробелов,
после последнего слова точка. Напечатать все слова, удалив из них две последние буквы.Ответы на вопрос
l,i:integer;
s,w:string;
prt:boolean;
c:char;
begin
{ s:=' Арбуз вагон барабан Goodday dummy. '; }
Write('Введите строку: ');
Readln(s);
l:=Pos('.',s);
s:=Copy(s,1,l-1)+' ';
i:=1;
prt:=False;
w:='';
while i<=l do
begin
c:=s[i];
if c=' ' then
begin
if prt then
begin
if Length(w)>2 then Write(Copy(w,1,Length(w)-2),' ');
w:='';
prt:=not prt
end
end
else
begin
w:=w+s[i];
prt:=True
end;
Inc(i)
end;
Writeln
end.
i:integer;
begin
writeln('Введите строку:');
readln(s1);
while pos(' ',s1)>0 do delete(s1,pos(' ',s1),1);
s1[length(s1)]:=' ';
s2:='';
for i:=1 to length(s1)-2 do
if (s1[i+2]<>' ')and(s1[i+1]<>' ')
then s2:=s2+s1[i];
writeln(s2);
end.
Пример:
Введите строку:
все слова удалив две последние буквы.
в сло удал д последн бук
Я могу помочь тебе с программированием на языке PascalABC.NET. Я нашел несколько результатов поиска, которые могут быть полезны для твоего задания.
Вот один из них, который содержит описание языка PascalABC.NET и его особенностей. Там ты можешь узнать, как работать со строками, массивами, циклами и другими элементами языка.
Для решения твоего задания тебе нужно написать программу, которая считывает текст из файла или с клавиатуры, разбивает его на слова по пробелам, удаляет из каждого слова две последние буквы и выводит полученные слова на экран или в файл. Вот пример такой программы:
```pascal var s: string; // переменная для хранения текста words: array of string; // массив для хранения слов i: integer; // переменная для цикла begin readln(s); // считываем текст с клавиатуры words := s.Split(' '); // разбиваем текст на слова по пробелам for i := 0 to words.Length - 1 do // перебираем все слова в массиве if words[i].Length >= 2 then // если длина слова больше или равна двум writeln(words[i].Remove(words[i].Length - 2)); // выводим слово без двух последних букв end. ```
Надеюсь, это поможет тебе с твоим заданием. Удачи!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
