Вопрос задан 29.10.2023 в 19:49.
Предмет Информатика.
Спрашивает Михеев Артемий.
Напишите программу в , C++, которая в последовательности натуральных чисел определяет сумму чисел,
кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6.Программа должна быть рабочейОтветы на вопрос
Отвечает Ознобихин Матвей.
#include <iostream>
using namespace std;
int main() {
int n = 0;
setlocale (LC_ALL, "Russian");
cout << "Введите количество чисел: ";
cin >> n;
int sum(0);
int a[n];
for(int i = 0; i < n; ++i) {
abc:
cout << "№" << i << ": ";
cin >> a[i];
if(a[i]>300||a[i]%6!=0) {
cout << "Число превышает 300 или не кратно 6. Повторите ввод" << endl;
goto abc;
}
if(0 == a[i]%6) {
sum += a[i];
}
}
cout << "Сумма введённых чисел, кратных 6: " << sum;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на C++, которая выполняет описанную вами задачу:
```cpp
#include
int main() {
int n; // количество чисел в последовательности
std::cout << "Введите количество чисел в последовательности: ";
std::cin >> n;
int sum = 0; // переменная для хранения суммы чисел, кратных 6
for (int i = 0; i < n; ++i) {
int num; // текущее введенное число
std::cout << "Введите число " << (i + 1) << ": ";
std::cin >> num;
// Проверяем, кратно ли число 6, и если да, добавляем его к сумме
if (num % 6 == 0) {
sum += num;
}
}
std::cout << "Сумма чисел, кратных 6, равна: " << sum << std::endl;
return 0;
}
```
Эта программа запрашивает у пользователя количество чисел в последовательности и затем поочередно вводит сами числа. Если число кратно 6, оно добавляется к сумме. По завершении ввода всех чисел программа выводит сумму чисел, кратных 6.
0
0
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
