
Вопрос задан 28.10.2023 в 06:41.
Предмет Информатика.
Спрашивает Маслак Анастасия.
Задачи на массив в Turbo Pascal 1) Определите ,на сколько отличается рост самого
высокого и самого низкого учащегося в классе?2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива -год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура

Ответы на вопрос

Отвечает Кушнырева Ульяна.
Program gt;
var n,i,max,min:integer;
a:array[1..100]of integer;
begin
read(n);
{n-кол-во учащихся}
for i:=1 to n do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
writeln(max,' ',min,'-росты')
max:=max-min;
writeln(max);
end.
2)
program gt;
var n,i,a,k:integer;
begin
read(n);
k:=0;
for i:=1 to n do
begin
read(a);
if(a<1958)then k:=k+1;
end;
writeln(k);
end.
3)
program gt;
var i,q,a,l:integer;
begin
for i:=8 to 20 do
begin
read(a);
if(a<0)then begin
q:=q+1;
if(q=1)then l:=i;
end;
end;
writeln(l);
end.
var n,i,max,min:integer;
a:array[1..100]of integer;
begin
read(n);
{n-кол-во учащихся}
for i:=1 to n do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
writeln(max,' ',min,'-росты')
max:=max-min;
writeln(max);
end.
2)
program gt;
var n,i,a,k:integer;
begin
read(n);
k:=0;
for i:=1 to n do
begin
read(a);
if(a<1958)then k:=k+1;
end;
writeln(k);
end.
3)
program gt;
var i,q,a,l:integer;
begin
for i:=8 to 20 do
begin
read(a);
if(a<0)then begin
q:=q+1;
if(q=1)then l:=i;
end;
end;
writeln(l);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
1) Для решения первой задачи создадим массив роста учащихся класса и заполним его значениями. Затем, используя переменные для хранения минимального и максимального значения роста, пройдем по всем элементам массива и сравним их со значениями минимального и максимального роста. Если текущий элемент больше максимального значения, обновим значение максимального роста. Если текущий элемент меньше минимального значения, обновим значение минимального роста. По окончании цикла вычислим разницу между максимальным и минимальным ростом.
Код на Turbo Pascal:
```
const
N = 5; // количество учащихся в классе
var
heights: array[1..N] of Integer; // массив роста учащихся
i, min_height, max_height, difference: Integer; // переменные для работы с массивом
begin
// Ввод роста учащихся
writeln('Введите рост учащихся:');
for i := 1 to N do
begin
write('Учащийся ', i, ': ');
readln(heights[i]);
end;
// Нахождение разницы между самым высоким и самым низким учащимся
min_height := heights[1];
max_height := heights[1];
for i := 2 to N do
begin
if heights[i] < min_height then
min_height := heights[i];
if heights[i] > max_height then
max_height := heights[i];
end;
difference := max_height - min_height;
writeln('Разница в росте между самым высоким и самым низким учащимся: ', difference, ' см');
readln;
end.
```
2) Во второй задаче создадим массив годов рождения жителей и заполним его данными. Затем, используя переменную для хранения общего числа жителей, пройдем по всем элементам массива и проверим, является ли текущий год рождения меньше 1958. Если условие выполняется, увеличим значение переменной общего числа жителей.
Код на Turbo Pascal:
```
const
N = 10; // общее количество жителей
var
birth_years: array[1..N] of Integer; // массив годов рождения жителей
i, count: Integer; // переменные для работы с массивом
begin
// Ввод годов рождения жителей
writeln('Введите годы рождения жителей:');
for i := 1 to N do
begin
write('Житель ', i, ': ');
readln(birth_years[i]);
end;
// Подсчет общего числа жителей, родившихся раньше 1958 года
count := 0;
for i := 1 to N do
begin
if birth_years[i] < 1958 then
count := count + 1;
end;
writeln('Общее число жителей, родившихся раньше 1958 года: ', count);
readln;
end.
```
3) Для решения третьей задачи создадим массив для хранения температур воздуха в течение дня и заполним его значениями. Затем, используя переменную для хранения индекса часа, в котором была впервые отмечена отрицательная температура, пройдем по всем элементам массива. Если текущая температура меньше нуля и индекс часа равен 0, запишем в переменную значение текущего индекса.
Код на Turbo Pascal:
```
const
N = 13; // количество часов в диапазоне от 8 до 20
var
temperatures: array[1..N] of Integer; // массив температур воздуха
i, first_negative_hour: Integer; // переменные для работы с массивом
begin
// Ввод температур воздуха
writeln('Введите температуры воздуха:');
for i := 1 to N do
begin
write('В ', i + 7, ':00 часов: ');
readln(temperatures[i]);
end;
// Определение часа, в котором была впервые отмечена отрицательная температура
first_negative_hour := 0;
for i := 1 to N do
begin
if (temperatures[i] < 0) and (first_negative_hour = 0) then
first_negative_hour := i + 7;
end;
writeln('Первый час, в котором была отмечена отрицательная температура: ', first_negative_hour, ':00');
readln;
end.
```
Обратите внимание, что данные коды ориентированы на работу в среде Turbo Pascal, где ввод и вывод данных происходит через консольный ввод-вывод.
0
0


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili