Вопрос задан 27.10.2023 в 18:22. Предмет Информатика. Спрашивает Коханевич Влад.

Помогите написать программу на языке С++:С клавиатуры сначала вводится количество символов k, а

затем последовательно вводятся k символов. Подсчитать среди них количество (m) букв нижнего регистра и вывести это значение на экран.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нестёркина Настя.

В приложениях находятся два варианта решений. Постановка задачи позволяет решить ее без использования массивов. Такой код находится во втором приложении.



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке C++, которая выполняет задачу подсчета количества букв нижнего регистра в последовательности символов:

```cpp #include using namespace std;

int main() { int k; // Количество символов int m = 0; // Счетчик букв нижнего регистра char ch; // Переменная для ввода символов

cout << "Введите количество символов k: "; cin >> k;

cout << "Введите последовательно " << k << " символов: "; for (int i = 0; i < k; i++) { cin >> ch;

// Проверяем, является ли символ буквой нижнего регистра if (islower(ch)) { m++; } }

cout << "Количество букв нижнего регистра: " << m << endl;

return 0; } ```

Программа сначала запрашивает у пользователя количество символов `k`, затем последовательно вводит `k` символов. Для каждого символа она использует функцию `islower` из библиотеки ``, чтобы проверить, является ли символ буквой нижнего регистра, и если да, увеличивает счетчик `m`. В конце программа выводит количество букв нижнего регистра на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос