Составить программу в Pascal... 1.Площадь треугольника по 3-м его сторонам: Var a,b,c, P:
integer; PP, S: real; Begin (дальше)Ответы на вопрос
Площадь треугольника по 3-м его сторонам:
Var a,b,c, P: integer;
PP, S: real;
Begin
readln(a);
readln(b);
readln(c);
PP := ( a + b + c ) / 2;
S := sqrt(PP*(PP-a)*(PP-b)*(PP-c));
writeln('Ответ(округлен до тысячных): ' + S:0:3);
end.
Для составления программы на Pascal, которая вычисляет площадь треугольника по трем его сторонам, вам потребуется использовать формулу Герона.
Формула Герона для вычисления площади треугольника по его сторонам \(a\), \(b\) и \(c\) выглядит следующим образом:
\[S = \sqrt{p \cdot (p - a) \cdot (p - b) \cdot (p - c)}\]
где \(p\) - полупериметр, вычисляемый как \(\frac{{a + b + c}}{2}\).
Программа на Pascal может выглядеть следующим образом:
```pascal program CalculateTriangleArea;
var a, b, c: integer; p, S: real;
begin { Вводим длины сторон треугольника } writeln('Введите длину стороны a: '); readln(a); writeln('Введите длину стороны b: '); readln(b); writeln('Введите длину стороны c: '); readln(c);
{ Вычисляем полупериметр } p := (a + b + c) / 2;
{ Проверяем условие существования треугольника } if (a + b > c) and (a + c > b) and (b + c > a) then begin { Вычисляем площадь треугольника } S := sqrt(p * (p - a) * (p - b) * (p - c));
{ Выводим площадь треугольника } writeln('Площадь треугольника: ', S:0:2); end else writeln('Треугольник с такими сторонами не существует.');
readln; // Ждем, пока пользователь нажмет Enter, чтобы закрыть программу end. ```
В этой программе пользователь вводит длины трех сторон треугольника. Затем программа вычисляет полупериметр \(p\) и проверяет, существует ли треугольник с такими сторонами. Если условие существования выполнено, программа вычисляет площадь и выводит её на экран. Если треугольник не существует, программа сообщает об этом.
Не забудьте, что в Pascal для вычисления квадратного корня используется функция `sqrt()`.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
