Напишите программу Паскаль срочно пожалуйста даю 40 балов Найти сумму нечётных чисел кратных 3
которые заканчиваются цифрой 5.Ответы на вопрос
i,s,n,m:integer;
begin
Write('Количество чисел равно ');
Readln(n);
s:=0;
Writeln('Введите все числа');
for i:=1 to n do
begin
Read(m);
if (abs(m mod 10)=5) and (m mod 3=0) then s:=s+m
end;
Writeln('s=',s)
end.
Конечно, я могу помочь вам написать программу на языке Паскаль, которая будет находить сумму всех нечетных чисел, кратных 3, и заканчивающихся на цифру 5.
Приведенный ниже код демонстрирует, как это можно сделать:
``` program SumOfOddNumbers; var i, sum: integer; begin sum := 0; for i := 15 to 10000 step 10 do begin if (i mod 3 = 0) and (i mod 2 <> 0) then sum := sum + i; end; writeln('Сумма нечетных чисел, кратных 3 и заканчивающихся на 5: ', sum); end. ```
В этой программе цикл `for` проходит от 15 до 10000 с шагом 10. Так как мы ищем числа, которые заканчиваются на 5, мы начинаем с 15 (первое нечетное число, которое заканчивается на 5) и увеличиваем его на 10 на каждой итерации цикла.
Внутри цикла мы проверяем, является ли текущее число `i` кратным 3 и нечетным. Если это так, мы добавляем его к `sum`.
В конце программы выводится значение `sum`, которое будет являться суммой всех нечетных чисел, кратных 3 и заканчивающихся на 5 в диапазоне от 15 до 10000.
Пожалуйста, учтите, что код написан на основе стандарта Free Pascal. Если вы используете другой компилятор Паскаль, возможно, потребуется небольшая модификация кода.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
