Вопрос задан 26.10.2023 в 16:32.
Предмет Информатика.
Спрашивает Гильмутдинов Роман.
Составьте программу в Паскале для поиска: a)суммы положительных элементов массива от а от 1 до
100, введенных с клавиатурыb) произведения отрицательных элементов массива а от 1 до 100c) количества нулевых элементов массива с сотней элементовОтветы на вопрос
Отвечает Печерица Людмила.
А) uses crt;
const n=10;
var a:array[1..n] of integer;
i,sum:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100)-50;
write(a[i]:4);
if a[i]>0 then sum:=sum+a[i];
end;
writeln;
writeln('Сумма положительных элементов = ',sum);
end.
const n=10;
var a:array[1..n] of integer;
i,sum:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100)-50;
write(a[i]:4);
if a[i]>0 then sum:=sum+a[i];
end;
writeln;
writeln('Сумма положительных элементов = ',sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Pascal, которая выполняет указанные задачи:
pascalprogram ArrayOperations; var arr: array[1..100] of integer; i, sumPositives, productNegatives, zeroCount: integer; begin sumPositives := 0; productNegatives := 1; zeroCount := 0; writeln('Введите элементы массива (100 элементов):'); for i := 1 to 100 do begin write('Элемент ', i, ': '); readln(arr[i]); if arr[i] > 0 then sumPositives := sumPositives + arr[i) else if arr[i] < 0 then productNegatives := productNegatives * arr[i) else zeroCount := zeroCount + 1; end; writeln('Сумма положительных элементов: ', sumPositives); writeln('Произведение отрицательных элементов: ', productNegatives); writeln('Количество нулевых элементов: ', zeroCount); end.
Программа создает массив arr из 100 элементов и запрашивает у пользователя ввод значений для каждого элемента. Затем она выполняет требуемые операции для положительных, отрицательных и нулевых элементов, выводит результаты на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
