
Вопрос задан 26.10.2023 в 12:20.
Предмет Информатика.
Спрашивает Смирнов Костя.
Нужна помощь по информатике, программа в Паскаль.ЗАДАЧА.В массиве хранится о численности книг в
каждом из 35 разделов библиотеки. Выяснить, верно ли, что общее число книг в библиотеке есть шестезначное число?

Ответы на вопрос

Отвечает Щепакова Жанна.
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ArrRandom(35,100,50000); a.Println;
var k:=a.Sum;
Write('Всего книг ',k);
if (k>=1000000) and (k<=9999999) then
Writeln(' - шестизначное число')
else Writeln(' - не шестизначное число')
end.
Тестовые решения:
44847 40059 3938 43998 48227 2295 18961 36991 30123 41620 22198 13146 38442 8318 35835 49112 33119 4617 20383 19164 6367 30588 40391 31807 32046 49835 4990 817 31748 21075 16466 17557 44413 12879 803
Всего книг 897175 - не шестизначное число
36802 44900 5012 30120 29288 21787 24640 41798 38286 34288 3756 5543 765 28259 26754 29598 15994 40577 26492 10557 41597 48459 13095 29019 30351 47939 35197 10527 43439 21960 40977 41831 43125 48076 10234
Всего книг 1001042 - шестизначное число
begin
var a:=ArrRandom(35,100,50000); a.Println;
var k:=a.Sum;
Write('Всего книг ',k);
if (k>=1000000) and (k<=9999999) then
Writeln(' - шестизначное число')
else Writeln(' - не шестизначное число')
end.
Тестовые решения:
44847 40059 3938 43998 48227 2295 18961 36991 30123 41620 22198 13146 38442 8318 35835 49112 33119 4617 20383 19164 6367 30588 40391 31807 32046 49835 4990 817 31748 21075 16466 17557 44413 12879 803
Всего книг 897175 - не шестизначное число
36802 44900 5012 30120 29288 21787 24640 41798 38286 34288 3756 5543 765 28259 26754 29598 15994 40577 26492 10557 41597 48459 13095 29019 30351 47939 35197 10527 43439 21960 40977 41831 43125 48076 10234
Всего книг 1001042 - шестизначное число



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи вам нужно будет написать программу на языке Паскаль, которая будет считать общее число книг в библиотеке и затем проверять, является ли это число шестизначным.
Вот пример программы на Паскале:
pascalprogram LibraryBooks; var bookCounts: array[1..35] of integer; // массив с численностью книг в каждом разделе totalBooks: integer; // общее число книг в библиотеке begin // Ввод численности книг в каждом разделе for i := 1 to 35 do begin writeln('Введите число книг в разделе ', i, ': '); readln(bookCounts[i]); end; // Считаем общее число книг в библиотеке totalBooks := 0; for i := 1 to 35 do begin totalBooks := totalBooks + bookCounts[i]; end; // Проверяем, является ли общее число книг шестизначным if (totalBooks >= 100000) and (totalBooks <= 999999) then writeln('Общее число книг в библиотеке - шестизначное число.') else writeln('Общее число книг в библиотеке не является шестизначным числом.'); end.
В этой программе мы сначала вводим численность книг в каждом разделе библиотеки, затем считаем общее число книг и, наконец, проверяем, является ли оно шестизначным числом.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 575

Информатика 33

Информатика 39

Информатика 24

Информатика 34

Информатика 136

Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili