МНОГО ПУНКТОВ. (Линейное) Программирование.ПАСКАЛЬ. Задачи ОЧЕНЬ ЛЕГКИЕ, пропустила много. Хочу
разобраться. БОЛЬШОЕ СПАСИБО ЗА ПРАВИЛЬНОЕ РЕШЕНИЕ) Карточка 1. 1. Вычислите дробную часть среднего арифметического трех заданных чисел. 2. Составьте программу вычисления идеального веса человека по его росту, при условии. что идеальный вес (кг)=(рост(см) - 100 3. Рассчитайте, сколько очков набрала команда по хоккею, если известно, что m встреч онавыиграла (2 очка), n встреч она проиграла (0 очков) и k встреч - ничья (1 очко). 4.1 Дано целое число. Определить является ли оно четным. 4.2 Дано целое число. Определить оканчивается ли оно цифрой 7. Карточка 2. ( необходимо знание формул по физике) 1. Даны объем и массы двух тел из разных материалов. Материал какого из тел имеет большую плотность? 2. Известны напряжения двух не соединенных друг с другом участков электрическлй цепи и напряжения на каждом из них. По какому участку протекает меньший ток?Ответы на вопрос
var a,b,c,s:integer;
begin
read(a);
read(b);
read(c);
s:=(a+b+c) mod 3 mod вробная часть от деления
end;
var post,Bes:real;
begin
read(post);
Bes:=post-100; (кг)=(рост(см) - 100
end;
var m,n,k:integer;
begin
read(m);
read(n);
read(k);
o:=m*2+n*0+k*1
end;
var x:integer;
begin
read(x);
if x mod 2 =0 then write('чот') else write('нечет');
end;
var x:integer;
begin
read(x);
if x mod 10=7 then write('на конце 7') else write('не 7');
end;
///write(x) выводит значение переменой;
Конечно, я могу помочь вам с решением этих задач на языке программирования Паскаль.
Карточка 1:
Вычислите дробную часть среднего арифметического трех заданных чисел.
pascalprogram AverageFractionalPart; var num1, num2, num3, average: real; begin write('Введите первое число: '); readln(num1); write('Введите второе число: '); readln(num2); write('Введите третье число: '); readln(num3); average := (num1 + num2 + num3) / 3; writeln('Дробная часть среднего арифметического: ', frac(average)); end.Составьте программу вычисления идеального веса человека по его росту.
pascalprogram IdealWeight; var height, idealWeight: real; begin write('Введите рост (в см): '); readln(height); idealWeight := (height - 100); writeln('Идеальный вес (кг): ', idealWeight:0:2); end.Рассчитайте, сколько очков набрала команда по хоккею.
pascalprogram HockeyPoints; var wins, losses, draws, totalPoints: integer; begin write('Количество выигранных матчей: '); readln(wins); write('Количество проигранных матчей: '); readln(losses); write('Количество ничьих матчей: '); readln(draws); totalPoints := (wins * 2) + (draws * 1); writeln('Команда набрала ', totalPoints, ' очков.'); end.
4.1. Определите, является ли целое число четным.
pascalprogram IsEven; var number: integer; begin write('Введите целое число: '); readln(number); if (number mod 2 = 0) then writeln('Число четное.') else writeln('Число нечетное.'); end.
4.2. Определите, оканчивается ли целое число цифрой 7.
pascalprogram EndsIn7; var number: integer; begin write('Введите целое число: '); readln(number); if (number mod 10 = 7) then writeln('Число оканчивается на 7.') else writeln('Число не оканчивается на 7.'); end.
Карточка 2:
Даны объем и масса двух тел из разных материалов. Материал какого из тел имеет большую плотность?
pascalprogram DensityComparison; var volume1, mass1, density1, volume2, mass2, density2: real; begin write('Введите объем первого тела (в м^3): '); readln(volume1); write('Введите массу первого тела (в кг): '); readln(mass1); write('Введите объем второго тела (в м^3): '); readln(volume2); write('Введите массу второго тела (в кг): '); readln(mass2); density1 := mass1 / volume1; density2 := mass2 / volume2; if density1 > density2 then writeln('Плотность первого тела больше.') else if density2 > density1 then writeln('Плотность второго тела больше.') else writeln('Плотность обоих тел одинакова.'); end.Известны напряжения двух не соединенных друг с другом участков электрической цепи и напряжения на каждом из них. По какому участку протекает меньший ток?
Для этой задачи необходимо знать также сопротивления участков цепи, чтобы рассчитать ток. Вы можете использовать закон Ома: I = U / R, где I - ток, U - напряжение, R - сопротивление. Вам нужно сравнить токи, протекающие через каждый участок, и определить, в каком участке ток меньше.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
