Вопрос задан 25.10.2023 в 11:52. Предмет Информатика. Спрашивает Назарова Таня.

Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000,

подсчитывает количество натуральных чисел, не кратных 3, на отрезке [a,b]. Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1≤a≤b≤30000. Проверять входные данные на корректность не нужно.Программа должна вывести одно число: количество натуральных чисел, не кратных 3, на отрезке [a,b]. Входные данные: 7 37 Выходные данные: 21 Пожалуйста!!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Курганская Анна.

Ответ:

Объяснение:

Python

a = int(input())

b = int(input())

s = 0

for i in range(a , b+1)

         if i%3!=0:

                    s+=1

print(s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи, можно написать программу на Python. Вот пример такой программы:

python
a, b = map(int, input().split()) count = 0 for num in range(a, b + 1): if num % 3 != 0: count += 1 print(count)

Вы можете ввести значения a и b с клавиатуры, и программа выведет количество натуральных чисел, не кратных 3, на отрезке от a до b. Ваш пример (входные данные: 7 37) даст следующий вывод: 21.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос