Вопрос задан 25.07.2018 в 11:52.
Предмет Информатика.
Спрашивает Ефремов Илья.
Составьте программу на языке Паскаль: Поменять местами первую и последнюю цифры четырёхзначного
числа. Очень срочно помогите пожалуйста!Ответы на вопрос
Отвечает Гайтан Даниил.
Var a,a1,a2,a3,a4;
begin
read (a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
a:=a4*1000+a2*100+a3*10+a1;
write (a);
end.
begin
read (a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
a:=a4*1000+a2*100+a3*10+a1;
write (a);
end.
Отвечает Жулябина Алёна.
Uses Crt;
var x : Integer;
Zn:Char;
strNum:string;
begin
ClrScr;
Write('Введите четырех значное число: ');
ReadLn(x);
Str(X,strNum);
Zn:=strNum[1];
strNum[1]:=strNum[Length(strNum)];
strNum[Length(strNum)]:=Zn;
x:=StrToInt(StrNum);
writeln(strNum);
end.
var x : Integer;
Zn:Char;
strNum:string;
begin
ClrScr;
Write('Введите четырех значное число: ');
ReadLn(x);
Str(X,strNum);
Zn:=strNum[1];
strNum[1]:=strNum[Length(strNum)];
strNum[Length(strNum)]:=Zn;
x:=StrToInt(StrNum);
writeln(strNum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Паскаль для обмена местами первой и последней цифры четырехзначного числа может выглядеть следующим образом:
```pascal program SwapFirstAndLastDigit;
var number, firstDigit, lastDigit, newNumber: integer;
begin write('Введите четырехзначное число: '); readln(number);
lastDigit := number mod 10; firstDigit := number div 1000;
newNumber := number - (firstDigit * 1000) - lastDigit + (lastDigit * 1000) + firstDigit;
writeln('Число после замены первой и последней цифры: ', newNumber); end. ```
Эта программа сначала запрашивает у пользователя ввести четырехзначное число. Затем она находит первую и последнюю цифры числа, меняет их местами и выводит результат.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
