Вопрос задан 23.10.2023 в 20:33. Предмет Информатика. Спрашивает Абзалов Алмаз.

1) Напишите программу, которая вводит трехзначное число и разбивает его на цифры. Пример: при вводе

числа 123 программа должна вывести "1, 2, 3" 2) Нужно написать такую же программу как и в первом номере,только для случайных чисел( не для трехзначного числа) Помогите пожалуйста Заранее огромнейшее спасибо
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Зенков Александр.

универсальный вариант. Долго над решением думать не хотелось, так что ответ такой.  Поскольку ограничений на решение не было)


//PascalABC.NET версия 3.4.0.1677 от 17.06.18

//Если программа не запускается, то обновите версию


var

   n: integer;

   s: string;

begin

   readln(n);  

   s := '';

   while n > 0 do

   begin

       s := (n mod 10).ToString() + '0

       ' + s;

       n := n div 10;

   end;

   

   writeln(s);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для выполнения задачи вам потребуется использовать язык программирования. Я предоставлю вам примеры кода на Python, который поможет выполнить обе задачи.

1) Разбиение трехзначного числа на цифры:

```python # Ввод трехзначного числа num = int(input("Введите трехзначное число: "))

# Проверка, что введено трехзначное число if 100 <= num <= 999: # Разбиваем число на цифры digit1 = num // 100 digit2 = (num // 10) % 10 digit3 = num % 10

# Выводим цифры print(f"{digit1}, {digit2}, {digit3}") else: print("Вы ввели не трехзначное число.") ```

Этот код сначала запрашивает у пользователя ввести трехзначное число, затем проверяет, является ли введенное число трехзначным, и разбивает его на цифры.

2) Разбиение случайного числа на цифры:

```python import random

# Генерируем случайное число от 100 до 999 num = random.randint(100, 999)

# Разбиваем число на цифры digit1 = num // 100 digit2 = (num // 10) % 10 digit3 = num % 10

# Выводим цифры print(f"Случайное число: {num}") print(f"{digit1}, {digit2}, {digit3}") ```

Этот код генерирует случайное трехзначное число от 100 до 999 и затем разбивает его на цифры, выводя их на экран.

Вы можете скопировать и вставить эти коды в среду разработки Python и выполнить их для выполнения задач.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос