Вопрос задан 23.10.2023 в 14:38. Предмет Информатика. Спрашивает Ильин Вадим.

Помогите пожалуйста написать программу в Python 3.0 Суточный рацион коровы составляет a кг сена,

b кг силоса и c кг комбикорма. В хозяйстве, содержащем стадо из k голов, осталось x центнеров сена, y тонн силоса и z мешков комбикорма по 50 кг. Сколько еще дней хозяйство сможет кормить коров по полному рациону?
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дружинин Валентин.
Запас сена составляет sx=50x кг, запас силоса sy=50y кг, запас комбикорма sz=50z кг.
За сутки k коров съедят dx=ka кг сена, dy=kb кг силоса и dz=kc кг комбикорма, после чего запасы уменьшаются:
sx=sx-dx, sy=sy-dy, sz=sz-dz. Этот процесс повторяется и прекращается, если выполняется хотя бы одно из условий:
sx<dx, sy<dy, sz<dz. Количество таких повторений будет ответом на задачу.

sx = 50*int(input("Мешков сена: "))
sy = 50*int(input("Мешков силоса: "))
sz = 50*int(input("Мешков комбикорма: "))
k = int(input("Количество голов в хозяйстве: "))
dx = k*int(input("Дневной рацион коровы (сено), кг: "))
dy = k*int(input("Дневной рацион коровы (силос), кг: "))
dz = k*int(input("Дневной рацион коровы (комбикорм), кг: "))
d=0
while sx>=dx and sy>=dy and sz>=dz:
    d+=1
    sx-=dx
    sy-=dy
    sz-=dz
print("Коров можно кормить еще "+str(d)+" дней (дня)")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, помогу! Вот пример программы на Python 3.0, которая решает вашу задачу:

python
def days_of_feeding(a, b, c, k, x, y, z): total_sena_needed = a * k total_silos_needed = b * k total_korma_needed = c * k remaining_sena = x * 100 # переводим центнеры в кг remaining_silos = y * 1000 # переводим тонны в кг remaining_korma = z * 50 # переводим мешки в кг days_sena = remaining_sena // total_sena_needed days_silos = remaining_silos // total_silos_needed days_korma = remaining_korma // total_korma_needed days_to_feed = min(days_sena, days_silos, days_korma) return days_to_feed # Пример использования a = float(input("Введите количество сена на одну корову в кг: ")) b = float(input("Введите количество силоса на одну корову в кг: ")) c = float(input("Введите количество комбикорма на одну корову в кг: ")) k = int(input("Введите количество коров в стаде: ")) x = float(input("Введите оставшееся количество сена в центнерах: ")) y = float(input("Введите оставшееся количество силоса в тоннах: ")) z = int(input("Введите оставшееся количество мешков комбикорма по 50 кг: ")) result = days_of_feeding(a, b, c, k, x, y, z) print(f"Хозяйство сможет кормить коров по полному рациону еще {result} дней.")

Просто введите необходимые данные, и программа выведет количество дней, в течение которых хозяйство сможет кормить коров по полному рациону.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос