Написать программу, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее
арифметическое. На паскале (через for to do)Ответы на вопрос
var a, b, c: real;
i : integer;
begin
b:=0;
for i:=1 to 5 do
begin
write('Введите число: ');
read(a);b:=b+a;
end;
c:= b/i;
writeln('Среднее арифметическое значение чисел: ', c);
end.

Для написания программы на Pascal, которая вводит с клавиатуры 5 вещественных чисел и вычисляет их среднее арифметическое, вы можете использовать следующий код:
pascalprogram AverageCalculator; var i: integer; num, sum: real; begin sum := 0; for i := 1 to 5 do begin write('Введите число ', i, ': '); readln(num); sum := sum + num; end; writeln('Среднее арифметическое: ', sum / 5:0:2); end.
Скопируйте этот код в среду разработки Pascal и выполните его. Программа попросит вас ввести 5 вещественных чисел, затем она вычислит и выведет среднее арифметическое этих чисел.
Вот пример программы на языке Pascal, которая вводит 5 вещественных чисел с клавиатуры и вычисляет их среднее арифметическое с использованием цикла for:
pascalprogram CalculateAverage; var i: Integer; num, sum, average: Real; begin sum := 0; for i := 1 to 5 do begin Write('Введите число ', i, ': '); Readln(num); sum := sum + num; end; average := sum / 5; writeln('Среднее арифметическое: ', average); Readln; end.
Эта программа сначала объявляет переменные i (используется для цикла), num (для ввода числа), sum (для суммирования чисел) и average (для хранения среднего арифметического). Затем она вводит 5 чисел с клавиатуры с помощью цикла for и суммирует их. Наконец, программа вычисляет среднее арифметическое путем деления суммы на 5 и выводит результат на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
