Вопрос задан 23.10.2023 в 01:42. Предмет Информатика. Спрашивает Миронский Павел.

Написать программу на паскале и нарисовать блок схему. Стоимости покупки с учетом скидки в 10%,

если сумма покупки больше 1000 рублей Сумма покупки 1200 со скидкой 1090
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Llorens Natasha.
Var s:real;
begin
write('s='); readln(s);
if s>1000 then s:=s-0.01*s;
writeln('S=',s); 
end.

Пример:
s=1200
S=1020

Блок-схема - в прилагаемом файле

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Хорошо, вот программа на Pascal:

pascal
program CalculateDiscount; var totalAmount, discountedAmount: real; begin write('Введите сумму покупки: '); readln(totalAmount); if totalAmount > 1000 then discountedAmount := totalAmount * 0.9 else discountedAmount := totalAmount; writeln('Сумма покупки с учетом скидки: ', discountedAmount:0:2); end.

Эта программа запрашивает у пользователя сумму покупки (totalAmount). Затем она проверяет, превышает ли сумма покупки 1000 рублей. Если да, то применяется скидка в 10% (умножение на 0.9), иначе скидка не применяется.

А вот блок-схема:

scss
[Введите сумму покупки] --> (totalAmount) | | v [totalAmount > 1000] --да--> [discountedAmount = totalAmount * 0.9] --> [Вывод суммы с учетом скидки] | |---нет---> v [discountedAmount = totalAmount] --> [Вывод суммы с учетом скидки]

Надеюсь, это помогло! Если у вас есть ещё какие-то вопросы, пожалуйста, дайте знать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос