Помогите срочно! Напишите программу. 1). Дан радиус шара. Найти его объём. 2). Даны стороны
треугольника: a,b,c. Вычислить косинусы углов по теореме косинусов. 3). Опредедить, сколько полных часов и полных минут прошло к этому моменту от начала суток. 4). Три сопротивления R1, R2 и R3 соединены параллельно. Найти сопротивление соединения R0. Идёт k-аяОтветы на вопрос
var
R,V: Real;
begin
ReadLn(R);
V:= (4/3)*pi*sqr(R)*R;
WriteLn(V);
ReadLn;
end.
2._________________
var
a, b, c, CAB, CBA, ACB: Real;
begin
writeln('vvedite storonu a'); readln (a);
writeln('vvedite storonu b'); readln (b);
writeln('vvedite storonu c'); readln (c);
CAB:=(sqr(c)-sqr(a)-sqr(b))/(-2*a*b);
CBA:=(sqr(a)-sqr(b)-sqr(c))/(-2*b*c);
ACB:=(sqr(b)-sqr(a)-sqr(c))/(-2*a*c);
writeln('ugol CAB =', CAB:3:2 );
writeln('ugol = CBA = ', CBA:3:2 );
writeln('ugol = ACB = ', ACB:3:2 );
readln;
end.
3._________________
//uses crt;
var
k: Integer; // Идёт k-ая секунда
begin
ReadLn(k);
WriteLn('Часов:', k div 3600);
While k>=3600 do k:= k - 3600;
WriteLn('Минут:', k div 60);
end.
4._________________
var
R1, R2, R3, R0: Real;
begin
WriteLn('Vvedite R1 ='); ReadLn(R1);
WriteLn('Vvedite R2 ='); ReadLn(R2);
WriteLn('Vvedite R3 ='); ReadLn(R3);
R0:=1/(1/R1+1/R2+1/R3);
WriteLn('Soprotivlenie = ', R0);
ReadLn;
end.
Конечно, я могу помочь вам написать программу для выполнения этих задач на языке Python. Вот код для каждой из задач:
1. Найти объем шара по его радиусу:
```python import math
radius = float(input("Введите радиус шара: ")) volume = (4/3) * math.pi * radius**3 print(f"Объем шара: {volume}") ```
2. Вычислить косинусы углов треугольника по его сторонам, используя теорему косинусов:
```python import math
a = float(input("Введите длину стороны a: ")) b = float(input("Введите длину стороны b: ")) c = float(input("Введите длину стороны c: "))
# Находим косинусы углов по теореме косинусов cos_A = (b2 + c2 - a**2) / (2 * b * c) cos_B = (c2 + a2 - b**2) / (2 * c * a) cos_C = (a2 + b2 - c**2) / (2 * a * b)
print(f"Косинус угла A: {cos_A}") print(f"Косинус угла B: {cos_B}") print(f"Косинус угла C: {cos_C}") ```
3. Определить, сколько полных часов и минут прошло с начала суток:
```python import datetime
now = datetime.datetime.now() hours = now.hour minutes = now.minute
print(f"Прошло {hours} часов и {minutes} минут с начала суток.") ```
4. Найти сопротивление соединения трех сопротивлений R1, R2 и R3, соединенных параллельно:
```python R1 = float(input("Введите сопротивление R1: ")) R2 = float(input("Введите сопротивление R2: ")) R3 = float(input("Введите сопротивление R3: "))
R0 = 1 / (1/R1 + 1/R2 + 1/R3) print(f"Сопротивление соединения: {R0}") ```
Вы можете ввести необходимые значения для каждой задачи, и программа выдаст вам соответствующие результаты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
