Вопрос задан 21.10.2023 в 21:59.
Предмет Информатика.
Спрашивает Маратканов Ростислав.
Pascal. Составить программу которая по видимому возрасту определяет приезжающего ребенка в отряд.
Ответы на вопрос
Отвечает Швец Марина.
Program zadacha;
var a: integer;
begin
writeln ('Введите возраст ребенка');
readln (a);
case a of
6,7: writeln ('5-ый отряд');
8,9: writeln ('4-ый отряд');
10,11: writeln ('3-ый отряд');
12,13: writeln ('2-ый отряд');
14,15: writeln ('1-ый отряд')
else writeln ('Ребенок слишком взрослый');
end;
end.
var a: integer;
begin
writeln ('Введите возраст ребенка');
readln (a);
case a of
6,7: writeln ('5-ый отряд');
8,9: writeln ('4-ый отряд');
10,11: writeln ('3-ый отряд');
12,13: writeln ('2-ый отряд');
14,15: writeln ('1-ый отряд')
else writeln ('Ребенок слишком взрослый');
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для определения приезжающего ребенка в отряд на основе его видимого возраста, вы можете использовать следующую программу на языке Pascal:
pascalprogram ОпределитьОтряд; var Возраст: integer; Отряд: string; begin writeln('Введите видимый возраст ребенка: '); readln(Возраст); if (Возраст >= 7) and (Возраст <= 12) then Отряд := 'Младший отряд' else if (Возраст >= 13) and (Возраст <= 17) then Отряд := 'Средний отряд' else if (Возраст >= 18) and (Возраст <= 21) then Отряд := 'Старший отряд' else Отряд := 'Не удается определить отряд'; writeln('Ребенок входит в отряд: ', Отряд); readln; end.
Эта программа позволяет ввести видимый возраст ребенка и затем определяет его отряд на основе указанных возрастных интервалов. Результат будет выведен на экране.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 30
Информатика 25
Информатика 101
Информатика 14
Информатика 501
Информатика 52
Информатика 42
Информатика 238
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
