Вопрос задан 21.10.2023 в 17:51.
Предмет Информатика.
Спрашивает Belchuk Lena.
Составить программу для вычисления величины S по формуле:
S=2(Σ^20[i=1]*cos(b^2[i])+e^^10[k=1]*z[k])program p5_4; var P,S,S1:real; i,k:integer; b:array[1..20] of integer; z:array[1..10] of integer; begin writeln(' z: '); for k:=1 to 10 do begin z[k]:=random(11)-5; write(z[k]:4); end; writeln; writeln(' b: '); for i:=1 to 20 do begin b[i]:=random(11)-5; write(b[i]:4); end; P:=1; S1:=0; for i:=1 to 20 do S1:=2*(S1+cos(sqr(b[i]))); for k:=1 to 10 do P:=P*(z[k]); S:=S1+P; writeln(' S=',S:2:5); end. Нам преподаватель сказал сделать без команды random, а я не пойму как она здесь будет выглядеть без random, так же и другая задача(((((Ответы на вопрос
Отвечает Сич Мирослава.
Без рандома:
program p5_4;
var
P,S,S1:real; i,k:integer;
b:array[1..20] of integer;
z:array[1..10] of integer;
begin
writeln(' z: ');
for k:=1 to 10 do
begin
Readln(z[k]);
write(z[k]:4);
end;
writeln;
writeln(' b: ');
for i:=1 to 20 do
begin
Readln(b[i]);
write(b[i]:4);
end;
P:=1;
S1:=0;
for i:=1 to 20 do
S1:=2*(S1+cos(sqr(b[i])));
for k:=1 to 10 do
P:=P*(z[k]);
S:=S1+P;
writeln(' S=',S:2:5);
end.
program p5_4;
var
P,S,S1:real; i,k:integer;
b:array[1..20] of integer;
z:array[1..10] of integer;
begin
writeln(' z: ');
for k:=1 to 10 do
begin
Readln(z[k]);
write(z[k]:4);
end;
writeln;
writeln(' b: ');
for i:=1 to 20 do
begin
Readln(b[i]);
write(b[i]:4);
end;
P:=1;
S1:=0;
for i:=1 to 20 do
S1:=2*(S1+cos(sqr(b[i])));
for k:=1 to 10 do
P:=P*(z[k]);
S:=S1+P;
writeln(' S=',S:2:5);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для того чтобы выполнить программу без использования функции random, вы можете вручную задать значения для массивов b и z. Вот пример, как это можно сделать:
pascalprogram p5_4; var P, S, S1: real; i, k: integer; b: array[1..20] of integer; z: array[1..10] of integer; begin // Задаем значения массива z вручную z[1] := 2; z[2] := -3; z[3] := 4; z[4] := 1; z[5] := -2; z[6] := 0; z[7] := 5; z[8] := -1; z[9] := 3; z[10] := -4; // Задаем значения массива b вручную b[1] := 1; b[2] := 2; b[3] := 3; b[4] := 4; b[5] := 5; b[6] := -1; b[7] := -2; b[8] := -3; b[9] := -4; b[10] := -5; b[11] := 1; b[12] := 2; b[13] := 3; b[14] := 4; b[15] := 5; b[16] := -1; b[17] := -2; b[18] := -3; b[19] := -4; b[20] := -5; P := 1; S1 := 0; for i := 1 to 20 do S1 := 2 * (S1 + cos(b[i] * b[i])); for k := 1 to 10 do P := P * z[k]; S := S1 + P; writeln('S=', S:2:5); end.
В этой версии программы значения массивов b и z заданы вручную, и они не зависят от генерации случайных чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 83
Информатика 45
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
